Nissan Titan Forum banner

1 - 20 of 47 Posts

·
Registered
Joined
·
3,324 Posts
Discussion Starter #1
I am really trying to enjoy my newly lifted T but its hard to with all the noises. It rides smooth on the interstate and handles bumps fine but going 15 mph and hitting the slightest bumps is unbearable. It sounds like I have rocks in the bed. The frt and rear squeaks very loud and are all rear remotes not fixed in that they swivel. I'm just guessing maybe this is the noise but its constant just cruising. Heres a video of me turning them side to side but imagine the shocks doing this 10x's faster and constant and thats what it sounds like.

the banging(guessing)
2011-04-29_16-46-38_727.mp4 video by rbessling - Photobucket

The squeak is constant
2011-04-10_12-28-06_150.mp4 video by rbessling - Photobucket
 

·
Registered
Joined
·
370 Posts
Wow, that sucks dude! I am not an expert but neither of those conditions seem right to me at all.
 

·
Registered
Joined
·
3,324 Posts
Discussion Starter #3 (Edited)
yes it does. I know nothings perfect but the money being spent on some of these mods, I think the need to be tested before they ship. I do not have the tools or means to just take them off and send them back to get fixed which means I would have to pay someone to take them off buy some temporary ones, etc. The thing is I was hoping someone that has these could confirm that this is just mine or if all Radflo's do this. These shocks seemed to get high reviews and that is why I picked them. Personally, I dont care how smooth they ride if the sound like junk when I pull up to places. I think they should be smooth and quiet for the money. I dont know what the rave is. they are no smoother than my factory shocks and the sound like junk. My truck seems bouncier going down the road now than it did with factory shocks too.
 

·
Registered
Joined
·
1,339 Posts
still hasnt been fixed huh....damn that blows...i had a nasty squeek goin on last couple weeks...crawled underneath and it was a loose lca camber bolt doesnt squeek nemore...i know its not ur prob and especially gettin the rads front and rear and there prol ur probs sucks hardcore brotha....what did ur lift guy say bout it all? heat shield on the rotor?
 

·
Registered
Joined
·
3,324 Posts
Discussion Starter #5
still hasnt been fixed huh....damn that blows...i had a nasty squeek goin on last couple weeks...crawled underneath and it was a loose lca camber bolt doesnt squeek nemore...i know its not ur prob and especially gettin the rads front and rear and there prol ur probs sucks hardcore brotha....what did ur lift guy say bout it all? heat shield on the rotor?
I'm really trying to enjoy this lift but it's hard. Its a love / hate relationship at this point...lol I think all the issues are in the shocks and rims and I'm willing to get to the bottom of it to keep my lift. I personally love being lifted and seems like I get a lot more stares but all the other noises might be getting a WTH stare. I fixed the dust shield by taking a flathead and wedging it between the shield and spindle and pushing it torwards the rotor...problem fixed. The tire rubbing doesn't even bother me that much and I could just do the PWM if I really wanted or Discount Tire said he has some 295x60x20 terra graaplers if I wanted them(he is the only one that has stepped up to help). I think its a 34.5" but I wouldn't have the trails then. He said last resort he would order me the same rims with a different offset to help clear the inside corner. Last is the noise from the frt and rear shocks. The rears sound like tools bouncing in the bed along with squeaks and is the one thing making me wanting to take it all off or I might just order other shocks that bolt on more snug and don't squeak.
 

·
Registered
Joined
·
1,339 Posts
for the price i loved the bilstein 5125's...dont you already have the pc rear shocks? and the spacer? why dont ya just switch the shocks out front and rear and see if it gets rid of the squeeks and pops? thats what i would do..try something and narrow down what the prob is
 

·
Registered
Joined
·
3,324 Posts
Discussion Starter #7
for the price i loved the bilstein 5125's...dont you already have the pc rear shocks? and the spacer? why dont ya just switch the shocks out front and rear and see if it gets rid of the squeeks and pops? thats what i would do..try something and narrow down what the prob is
I dont. I bought the kit minus the rear shocks and frt spacer since I thought I wouldn't need them and it shaved around $400 off. I might buy some rears 1st to problem solve and I'll have backups. If that fixes all the noise in the rear then I might just send them and the frts back to get fixed and then sell them and get some others.
 

·
Registered
Joined
·
14,135 Posts
are there supposed to be bushings on where the shock mounts to fix that banging sound? Just guessing. I have no idea. That just freakin sucks your still dealing with that.
 

·
Registered
Joined
·
3,324 Posts
Discussion Starter #9
are there supposed to be bushings on where the shock mounts to fix that banging sound? Just guessing. I have no idea. That just freakin sucks your still dealing with that.
Thats what I was hoping someone could answer for me that has them. I would be stoked to find out my issues were all simply fixes.
 

·
Registered
Joined
·
14,135 Posts
go on facebook, like the page PRG Products, and post on there those vid's. i know greg checks the page and responds on there. hopefully it doesnt offend him lol.
 

·
Registered
Joined
·
3,324 Posts
Discussion Starter #11
go on facebook, like the page PRG Products, and post on there those vid's. i know greg checks the page and responds on there. hopefully it doesnt offend him lol.
I emailed him and Radflo the video of the squeaks and both said WD40 and that they need to be broken in. I sprayed the mess out of them but nothing. I need to send one if it banging if I can fix the cam under there.
 

·
Registered
Joined
·
501 Posts
You need the replace those cheap a$$ bearings that Radflos uses. That shock should not move like that. Radflo coilovers are making the same knocking and that's suppose the problem. The rear shcoks are super easy to remove too remove. You really dont even need to jack it up if you're strong enough to compress the shock by hand.
 

·
Registered
Joined
·
3,324 Posts
Discussion Starter #13
You need the replace those cheap a$$ bearings that Radflos uses. That shock should not move like that. Radflo coilovers are making the same knocking and that's suppose the problem. The rear shcoks are super easy to remove too remove. You really dont even need to jack it up if you're strong enough to compress the shock by hand.
really? so you have radflo's too? this is good to hear as I can fix this asap and enjoy moving to the next mod...:)
 

·
Registered
Joined
·
1,173 Posts
Mine clank back and forth like that, Im not sure if thats a problem or not. As for the squeaking, Im pretty sure I read about that somewhere else with RadFlos and it was a new seal set up or something, sadly I dont remember how they fixed it or if they even did.
 

·
Registered
Joined
·
11,152 Posts
Mine clank back and forth like that, Im not sure if thats a problem or not. As for the squeaking, Im pretty sure I read about that somewhere else with RadFlos and it was a new seal set up or something, sadly I dont remember how they fixed it or if they even did.
You are correct. Radflow changed up their seals. Mine squeaked as well. Put WD40 on the shafts and the seal area and the mice went away.
 
1 - 20 of 47 Posts
Top