Nissan Titan Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 · (Edited)
This is in regards to all the posts about the 07 clicking drive line when taking off from drive or reverse. This was happening to mine intermittently and I could never duplicate it, pretty much the same issue as everyone else. I hesitated to even take it in cause I know what the dealer would say but I was messing around the other day and found a way to duplicate the clicking.

If I apply full pressure to the brake and give it half or full throttle it will duplicate the clicking noise every time, also when I let go of the gas and the RPMS go down it will give out another click. I don't know, maybe its just mine but those of you having the same problem try this out. At least I can bring it in now and show the dealership what it sounds like and they can see if whatever they do fixes it or not. From what I have read in the threads it seems like no dealer really fixed the problem for anyone..... Hope this helps, let me know if this works for anyone else???
 

·
Banned
Joined
·
27,783 Posts
Do you have the chrome wheels?
 

·
Registered
Joined
·
21 Posts
sounds like you have the same issue i have. mine goes in oct.22. the engineer from nissan is coming. a new rearend and drive shaft did not solve the clicking so dealer called engineer. yes it is loader if you power brake the truck, or take off hard. but sometimes it does it by just putting the truck in gear. i will try and post results. the site has not been letting me log on all the time.
 

·
Registered
Joined
·
21 Posts
Clicking solved! Engineer from Nissan fixed. Work order says, Lubricated splines on Differential input flange. Had to remove, grease, and install input flange at rear diff. This is the 4 bolt flange that attaches your drive shaft to your rear end.
 
1 - 5 of 5 Posts
Top