Nissan Titan Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Is anyone having issues with running E85 Flex fuel mine has started shuddering on cold start and check engine light has come on. But I like the increase in performance but not the decrease in MPG. Went from 15.3 to 13.9.But would like to know if there are others with same problems.Thanks
 

·
Registered
Joined
·
207 Posts
I have an E85 station about 10 minutes from my house, so I've tried it a few times. I've never had any issues with it. I don't run straight E85, though. I'll usually dilute it with about half 87 octane. In my area, E85 is about $1.55 a gallon, so the price is really nice!
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
I went to dealer today they reset ecm and told me number 6 was miss firing and that computer is telling me to use regular gas I find this disappointing to have a flex fuel vehicle that can't run flex fuel.So I guess I'll just run it every once and a while.
 

·
Registered
Joined
·
1,534 Posts
Tell them to fix the problem. If the truck is designed to run E85, then it should run E85. If ALL the cylinders were missing then I'd say it's the fuel. If the truck is new it should run fine on it. I'd guess its an injector or plug problem since it's specific to that cylinder.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
1,480 Posts
I run it slot. No issues. 2010 FF 204k miles
 
  • Like
Reactions: dhkwkid

·
Registered
Joined
·
407 Posts
Is this a new truck or an older one with some miles on it?

If it's anything over 70k miles then you should change the spark plugs and it'll probably be fine. They are rated to go longer but that doesn't mean you wont have issues with E85 and old plugs.
 
  • Like
Reactions: dhkwkid

·
Registered
Joined
·
407 Posts
2014 18,000 mi.
In that case get another dealer to look at it. It's very possible it's the Flex Fuel sensor that's not reading right.
 
1 - 10 of 10 Posts
Top