Nissan Titan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter #1
Hey Guys

So my e-brake exploded one day when towing a trailer. What I want to know is if anyone knows exactly what parts I need to replace while im in there, and if there is a step by step on how to do it or if I should just bring it to the shop and have it done there.

I know I need the shoes, the spring/clip kit w/ springs and adjusters. Do these kits come w/ the lever-toggle?.

When this happened my B-LSD and my ABS light came on and have not shut off since. Im assuming its because of the e-brake letting go. Am I correct?

Also my 4x4 will now not engage. The 4wd indiator light just blinks when I turn the dial and will not engage the front hubs. Could there be some kind of relation with everything? Are the sensors damged now and is that why the lights are staying on?
 

·
Premium Member
Joined
·
17,244 Posts
So my e-brake exploded one day when towing a trailer. What I want to know is if anyone knows exactly what parts I need to replace while im in there, and if there is a step by step on how to do it or if I should just bring it to the shop and have it done there.

I know I need the shoes, the spring/clip kit w/ springs and adjusters. Do these kits come w/ the lever-toggle?
This problem has been posted a few times. I don't think the kits come with the toggle, not sure. You may have to buy that separate. The pdf for the manual and some photos are in this thread:

http://www.titantalk.com/forums/titan-faq-howto-area/123384-replacing-axle-seals-w-pics.html

Not that hard to DIY although getting the toggle connected to the slotted end of the cable and getting the strong spring into place are a little bit of a PITA.



When this happened my B-LSD and my ABS light came on and have not shut off since. Im assuming its because of the e-brake letting go. Am I correct?

Also my 4x4 will now not engage. The 4wd indiator light just blinks when I turn the dial and will not engage the front hubs. Could there be some kind of relation with everything? Are the sensors damged now and is that why the lights are staying on?
Low brake fluid level can make the lights come on. I think damage to the wheel speed sensors or their associated cables can also make the lights come on and prevent shifting to 4wd. There is no electronics associated with the parking brake shoes at the rear wheels. The switch is up front, near the e-brake pedal.

The hubs on the Titan do not unlock, they are always engaged and thus the front diff and front drive shaft always turn. Shifting to 4wd happens at the transfer case via an electric actuator.

You might be able to get the code read at Autozone which might help diagnose the problem.
 

·
Registered
Joined
·
372 Posts
It is possible you damaged the sensor (ABS sensor I believe)
Under the parking brake shoes . It might be the reason for the warning lights
 

·
Registered
Joined
·
62 Posts
Discussion Starter #4
Ya some other guy stated he had this problem happen to his and that when the ebrak inploded it took out the sensor which in turn, didnt allow him to switch the truck into 4wd. I ordered the parts that i need to fix the ebrak, minus the wheel sensor and will hopfully get it put in this week. I will make sure I keep up the posts to let people know how things are going.
 

·
Registered
Joined
·
62 Posts
Discussion Starter #5
Hey thanks for the PDF link man. Im going to give it shot this week when the parts come in.
 
1 - 5 of 5 Posts
Top