Nissan Titan Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
452 Posts
Discussion Starter #1
I like to go mudding but last week my alternator went out due to the water. The tow truck driver was telling me about a part that acts as a splash guard for the motor. Does any one know of such a thing and where i could find one?
 

·
Registered
Joined
·
1,405 Posts
I've seen them on the copmpetition mud bog trucks but I don't think they would work on a daily driver truck because I think the engine would overheat due to lack of airflow.
 

·
Registered
Joined
·
3,921 Posts
First off why are you mudding in my truck :) second I have no idea, just being a smart arse while having my coffee.. Enjoy the mud!!!!
 

·
Registered
Joined
·
452 Posts
Discussion Starter #4
haha are trucks looks exactly the same but thanks for the replys im goin to have to keep looking for something to protect just the alternator so i can still get good airflow
 

·
Registered
Joined
·
3,921 Posts
Well the way I see it is if your gonna play you will have to pay. You will pay either in parts, stuff to help protect parts, better parts either way parts will break and you will still pay.
 

·
Premium Member
Joined
·
17,244 Posts
If I was going to be doing a bunch of mudding, I would pick a vehicle that has the alternator mounted much higher up. I would assume that serious mudders use a bracket for high mounting the alternator.

 

·
Registered
Joined
·
6,182 Posts
The first time I went to start mine, 2 days after I went "mudding" through muddy puddles, my Titan wouldn't start and it turned out the mud had gotten up on the stater motor, (which is located in the V of the engine), and had dried around the Bendix. The auto shop hosed it off for 5 minutes and it was fine since.
 

·
Registered
Joined
·
1,405 Posts
That's the one thing i've always like about the chevys is they always have their alternator up high and dry. I guess that just comes from decades of building trucks. You learn things after years and years and years of doing things.
 

·
Registered
Joined
·
452 Posts
Discussion Starter #9
ya well my battery light came on a couple days after i went and i took it up to the idiots at autozone and they said everything was working better than normal till one day a week later my truck shut down but the engine was still running but the gas just wouldnt go on the highway and the road warrior guy said thats what it was
 
1 - 9 of 9 Posts
Top