Nissan Titan Forum banner

1 - 20 of 30 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I was driving on the freeway today towing my boat for some afternoon fishing when all of sudden my engine shuts down on me. When I pulled over and tried to restart it, it would crank but would not fire at all. I had it towed to a dealership and when I got there a mechanic was able to start it up again. They are checking into it but I was wondering if any members here have this problem with their titan.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #2
My dealer say that they couldn't find any problems with the car. Cost me 232 bucks for nothing.
 

·
Premium Member
Joined
·
92,269 Posts

·
Premium Member
Joined
·
92,269 Posts

·
Premium Member
Joined
·
92,269 Posts
Yeah. Could be electrical. Could be computer-related. Could be O2 sensors. Could be fuel pump. Could be tons of stuff. Without a code, like BBF says, it's pretty much a stab in the dark.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
Update:
I picked my truck and drove it on the street and it was fine until I hit the freeway. Driving between 65-75 for 10 miles then suddenly lost power. Tried giving it gas but nothing so had to pull over and have it tow back to the same dealer. At least this time, I have a withness (tow truck guy) who couldn't start it either.

Weird thing was when we got back to the dealer, the damn thing started up again.

Tomorrow, I will take my video camrecorder and go take a test drive with the repair guy.
 

·
Premium Member
Joined
·
43,122 Posts
I bought a chevy aveo for the wife(now x) that had similar issues. Wouldn't shut all the way down but would lose power after driving for a while(signigicant)
after the 4th time we made them take the dam thing back! They never figured out what the problem was...........
GOOD LUCK!
 

·
Registered
Joined
·
1,147 Posts
Kinda sounds like a bad fuel pump.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #10
EVO8, you hit it right on the bullseye. That's what the dealer says and its the first for all the nissan dealers in Wisconsin. Total cost will be 1050.
 

·
Registered
Joined
·
1,147 Posts
That's one expensive fuel pump.
 

·
Premium Member
Joined
·
92,269 Posts
It's inside the tank, if I'm not mistaken. Not the easiest thing to get to....
 

·
Registered
Joined
·
10 Posts
Discussion Starter #14
Yeah, I think its still under warranty. I read it in my warranty book that the fuel pump is a component of the Engine which should fall in my drivetrain warranty. My titan is only 49000 miles. The dealer and Nissan say its not warranty but its in their warranty book unless there is a clause that I missed.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #15
I picked up my truck today and hasn't died yet. Cost was "0.00" since it was still under warranty.
 

·
Registered
Joined
·
908 Posts
dam that sucks. this thing is still happening in 2007?

almost the same thing happened to my sisters '79 volkswagen scirocco many many many years back. but in our case it would cut off while parked and on hot days. would not turn over. car had full battery, full electrical power with lights and all. but once it cooled down the car would start.

frickin annoying as hell, everything checked... then someone mentioned that since the car was EFI (electronic fuel injection) that it was the fuel pump. Pump was not feeding the gas when it was suppose to. we replaced the fuel pump and everthing was fine after that!
 

·
Registered
Joined
·
6,345 Posts
ditto happened to me in my 06, around 12000 miles... bad fuel pump, of course when the tow truck is there, it won't fire up... at the dealership, fired right up and they drove it into the bay... took day and half for them to figure out the pump was bad and replace it... cost nothing, had tow coverage and within warranty...
 

·
Registered
Joined
·
10 Posts
Discussion Starter #18
DRTY,
Is your fuel pump also for E85 flexfuel? Its probably a design issue with Nissan.
 

·
Registered
Joined
·
6,345 Posts
Vkue said:
DRTY,
Is your fuel pump also for E85 flexfuel? Its probably a design issue with Nissan.
Nope, standard fuel pump... supposedly this was the "first" fuel pump issue my dealership had seen with any of the Titans they sold...
 
1 - 20 of 30 Posts
Top