Nissan Titan Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
6,345 Posts
Discussion Starter #1
Okay, I am not a happy camper tonight... Let me start from three days ago... Three days ago, I am out running the kids around, school, sitter, etc. just as I usually do every weekday. I'm returning home on the highway, driving a modest 75 mph. I suddenly notice the SES is on steady. Get home, park it, check my fuel cap, and reset my ECU (five pumps of the gas, 10 count, hold down, 12 count, etc...) The SES is no longer on, and it stays off for the rest of the day.
Two days ago, run around the same as usual and again coming back home, this time very close to home, the SES lights up steady again. I detour to my dealership, and check on the wait for service. At least two hours before my Titan can even be seen, so I tell the service writer, I'll be back tomorow morning. On my way home, I run to the neighborhood Kragen and have the code read, P0420-three way (catalyst problem)... I get home, reset the ECU and no more SES once again.
This morning, same routine as usual and this time the SES comes on while I'm on the way to the sitter. I leave there, go to the dealership, drop the Titan off and have it looked at. The wife picks me up, I drop her off at work, use her Pathfinder for the day running errands.
About three hours later, the service writer calls me and tells me that they are done for the time being and I need to come get my Titan. I ask him what was wrong and he says that they don't know because they had to stop half way through the diagnostic test, due to the modified air intake (Volant CAI and PowerAid TBS that I installed0. I get there and talk to the service manager about the modified air intake and how that could possibly void the warranty.
He tells me that because it is modified from stock, they can't run a diagnostic under warranty and it would cost me $190 to have them run the diagnostic with it modified. I ask if I return the air intake system back to stock, will he be able to warranty it, and he says that he will be able to do it. So, I drive home, noticing that the SES light is now off. I get home and still no SES.
I take apart the TBS and CAI, install my OE intake and box w/ drop in K&N filter. I start the Titan, pull out of the driveway, and go get my kids from the sitter. I return home with the kids and almost get home, taking the offramp and about 2 miles from home. I feel like I am losing power and air compression, hear the rumbling of the engine as if there is a huge exhaust leak or bad compression. I drive the rest of the way home, playing with thr throttle and it just sounds worse, and definitely has no umph when I step on it.
I park the Titan in the driveway, get the kids inside to momma. I go back out and start the Titan up, leaving it in park, and giving it some throttle. The air is sucked in smoothly, the acceleration sounds good, but I hear this fast paced clicking and the rumble from the right side of the engine compartment. Uhoh... sounds like a rod, bearing, piston, or something internal. I get out on my neighborhood street and do some driving with some stopping and starting. I can accellerate smoothly but when I give it some more throttle, the engine definitely rumbles with the fast paced clicking heard like before, and it slowly accelerates (almost as if slipping gears). I am pissed, drive it home, and park it, seeing the wife looking at me through the interior garage doorway.
I step out, hearing her ask me, "what are you doing, it's already 11..." I give her an icy stare and say, "My truck's fuct up! I'm on my way in now..." I get inside, tell her I'm sorry for biting her head off, but I'm just frustrated at my Titan. I tell her to go to bed and not wait up, as I turn on my computer to post this.
Now, in the morning, I am going to slowly drive the Titan to the dealership. Talk directly to the service manager and tell him exactly how this went down this evening. Up until this, I have had no issues with my Titan. In fact, it has been awesome, but three days ago, this whole thing started and has gotten worse. Just a little internet venting... Oh yeah, my Titan has just about 22.5k miles, always had 5k or less interval services, using sythetic engine oil only.
 

·
Registered
Joined
·
1,400 Posts
I'm surprised they said they would look at it under warrenty if you put it back to stock.I really am.A lot of dealers wouldn't.I hope you get it fixed.
 

·
Registered
Joined
·
6,345 Posts
Discussion Starter #4
bestatchess said:
Cracked exhaust manifold? Injested catalyst?
You know... that could very well be... I recall reading about someone having that same issue... I do notice the rattle of metal, kinda like the shaking of a heatshield, exhaust pipe, or maybe... catalytic converter... I will post when I find out, in about half an hour, I'm taking her in...
 

·
Registered
Joined
·
6,345 Posts
Discussion Starter #5
okay, found out that the bank1 cat converter is torn up inside... the service writer told me that service manager will not authorize warranty since i modified the air intake... bull fahking ****! time to take the gloves off and go fight...
 

·
Registered
Joined
·
34,397 Posts
DRTYAZN said:
okay, found out that the bank1 cat converter is torn up inside... the service writer told me that service manager will not authorize warranty since i modified the air intake... bull fahking ****! time to take the gloves off and go fight...
That sucks!! Make sure they are aware of the Magnuson Moss Act!!! I think they gotta prove that the intake caused the problem.
 

·
Registered
Joined
·
6,345 Posts
Discussion Starter #8
well, I called consumer affairs, filed a grievance claim and was told I will be recontacted by close of business Monday... okay, so until then, I'm @$$ out of my truck??? "sorry for the inconvenience..." This is what my solution is... I am getting my Titan fixed, ($179 for the "diagnostic" + $1040 for the parts/labor, and don't forget about taxes... = about $1400), so I can have it and working this weekend. When I get my call back from consumer affairs, I will be battling to get a reimbursement now... if they do not than I guess my retained lawer will have to go to work!!!
 

·
Registered
Joined
·
514 Posts
Man that's shi**ty. Good luck .
 

·
Super Moderator
Joined
·
36,630 Posts
bestatchess said:
Cracked exhaust manifold? Injested catalyst?
I had cracked exhaust manifolds on mine ... sounds about the same
 

·
Registered
Joined
·
6,345 Posts
Discussion Starter #11
Okay, got the Titan back and it just doesn't feel like it had the same umph as before, probably all in my mind (I hope)... Got it home and re-installed my TBS and CAI, (I got this down to a 15 minute swap! that's about the only good thing that came out of his so far...) I reset the ECU and took it for a test drive. Of course I open her up as I get on the open road, 4 lane divided highway w/ center barricade so no Highway Patrol can whip a U on me... torque feels good and the pressure is there, so it appears as if everything for the moment is functional... Now to see what Nissan Customer Affairs have to say come Monday...
 

·
Registered
Joined
·
1,226 Posts
ive read a couple of threads saying how they found cracked exhaust manifolds and some clogged or broken catalytic converters. is this something we should all expect down the road? cant wait to read your out come.
 

·
Registered
Joined
·
2,955 Posts
gabriel c. said:
ive read a couple of threads saying how they found cracked exhaust manifolds and some clogged or broken catalytic converters. is this something we should all expect down the road? cant wait to read your out come.

Seems some of the cat failures are due to lean running condition, which causes them to heat quickly and begin to breakdown.
 

·
Registered
Joined
·
3,781 Posts
buzzkillwill said:
Seems some of the cat failures are due to lean running condition, which causes them to heat quickly and begin to breakdown.
anything we can do to avoid running lean? (short of NEVER modding?) how do i know if i'm running lean/rich?
 

·
Registered
Joined
·
1,400 Posts
I know it's too late now but I think you could of saved yourself a lot of trouble if you would have put it back to stock and took it to another dealer that would have never known you had a after market cai installed.
 

·
Registered
Joined
·
89 Posts
Speaking of engine troubles anybody have an annoying tick from the engine above 2 grand? under load or in neutral? Dealer said it was exhaust noise. Typical dealer response. the one i didnt want to hear
 

·
Registered
Joined
·
6,345 Posts
Discussion Starter #19
bestatchess said:
I thought it was supposed to throw an SES code.
Mine did... SES with code P0420 which is really generic for catalyst system error, (and NOT Maf sensor or Air Intake system error... but try to explain that to the service manager who reads from a service manual)

Cjack1 said:
Speaking of engine troubles anybody have an annoying tick from the engine above 2 grand? under load or in neutral? Dealer said it was exhaust noise. Typical dealer response. the one i didnt want to hear
That is something you might want to have them check... ticking is not good, especially if it's a cylinder knocking, or a loose cat core getting shaken inside the cat itself...
 

·
Registered
Joined
·
514 Posts
Lean could be from the air intake . More air and the the fuel not matching up. I don't know a lot about fuel injection but it seems like the computer should take care of that. Just thinking out loud. Maybe the stillen or up rev takes care of this .
 
1 - 20 of 26 Posts
Top