Nissan Titan Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
2008 4w. Has k&n cold air intake, drove to breck colorado and back to the eat coast changed o2 sensor, fuel pump went out on the way there. Fixed that, now back and service engine light came on on the way back. P0174 and p0171. System to lean. Says it's the catalytic converter but not sold on that. Idling it goes normal then drops...normal then drops is the pattern. Does seem to have a little less power on hills, but do 70 and set cruise control it runs like a dream. Anyone run into this?
 

·
Premium Member
Joined
·
68,096 Posts
Clean the MAF sensor with approved cleaner. Do you use an oiled air filter?
 

·
Registered
Joined
·
1,118 Posts
I say a bad O2 sensor. Swap the two front ones and see if the code moves to the other side. Need a special tool to get them off though


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
I changed the o2 sensor, it's in the middle of the air intake which is k&n and the filter is oiled. There is only one o2 sensor that I know of on this after market intake filter that was on it since I got it 2 yrs ago. "IF" it is the catalytic converter I see a few by flowmaster for 50-60 bucks that are universal but not sure what else I'd need and if it has a 2.. 2.5 ..or 3 inch outlet
 

·
Premium Member
Joined
·
68,096 Posts
The 02 sensor is in the exhaust. The MAF sensor is in the intake.
 

·
Registered
Joined
·
1,118 Posts
You haves 4 O2 sensors one on each front cat and one on each rear cat. Swap the front ones side to side then drive and see it f code switch’s sides


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
8 Posts
Discussion Starter #10
You haves 4 O2 sensors one on each front cat and one on each rear cat. Swap the front ones side to side then drive and see it f code switch’s sides


Sent from my iPhone using Tapatalk
It's on bank 1 and 2. I'll have to locate the sensors first somehow. I have been hearing a rattling underneath on and off that sounds like the cat converter, but no idea how to determine if it is actually the cc that is the issue... or a sensor.. or what.
 

·
Registered
Joined
·
47 Posts
I changed the o2 sensor, it's in the middle of the air intake which is k&n and the filter is oiled. There is only one o2 sensor that I know of on this after market intake filter that was on it since I got it 2 yrs ago. "IF" it is the catalytic converter I see a few by flowmaster for 50-60 bucks that are universal but not sure what else I'd need and if it has a 2.. 2.5 ..or 3 inch outlet
Wow just wow. That is an act sensor In the intake track. The o2 sensor is found on the exhaust side.
 

·
Registered
Joined
·
1,118 Posts
Gotta take the plastic off the front wheel wells then you can get to both front O2 sensors. You need a special tool to unscrew them then swap them


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
13 Posts
2008 4w. Has k&n cold air intake, drove to breck colorado and back to the eat coast changed o2 sensor, fuel pump went out on the way there. Fixed that, now back and service engine light came on on the way back. P0174 and p0171. System to lean. Says it's the catalytic converter but not sold on that. Idling it goes normal then drops...normal then drops is the pattern. Does seem to have a little less power on hills, but do 70 and set cruise control it runs like a dream. Anyone run into this?
I would start by cleaning the MAF sensor as it probably has oil on it from the K&N filter. Plus it wouldn't hurt anything to clean it . I clean mine about every 10K miles ; )
 
1 - 14 of 14 Posts
Top