Nissan Titan Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Hello,
I need some help getting my sirius radio up and running. I have an 04 with the RF system. I went online and bought the kit from Lee parts to with the sirius and the ipod. I hooked it up, and got the subscription. The ipod works fine, my subscription works when i log in online, but I don't get anything from the sirius. Is there anyone out there who has had a similar experience? Is there a way you can test the antenna, or do some other sort of trouble shooting? I installed it with my brother inlaw, who owns an auto electric store, so I am fairly confident that the wiring was done right.
 

·
Registered
Joined
·
2,006 Posts
You have to have the sat radio on, with a signal, while you are on the phone with them. I think it needs to be on channel 001. They send down a signal that activates the unit. Get out in the truck in the driveway with a clear view of sky with a phone and all of your account info, and call them. They should be able to help you. Good luck.
 

·
Registered
Joined
·
98 Posts
I had a similar experience with my XM install. I also have an '04 with RF system. My problem was either in the cable from the interface box to the XM tuner or in the antenna. I replaced the cable and messed around with the antenna and it started working.

FYI, my setup includes the XMD-1000 (tuner), AXXESS INTERFACE XIA-I01 and related cables. I did not use the pre-wire cable that was already under the dash, I went to the back of the head unit.

I'll try to answer anything I can, if you have specific quesitons.

It was frustrating trying to narrow down the problem, but so worth it!

Good Luck.
 

·
Registered
Joined
·
98 Posts
You have to have the sat radio on, with a signal, while you are on the phone with them. I think it needs to be on channel 001. They send down a signal that activates the unit. Get out in the truck in the driveway with a clear view of sky with a phone and all of your account info, and call them. They should be able to help you. Good luck.
My experience was if your unit would not receive the signal, they just tell you take it back to whoever installed it. Not the best advice when YOU are the installer! That's all the help I got.

I bought some of my equipment online from Radios and More. They were very helpful! Radios and More - CD Changers, In-Dash CD Changers, Car Navigation Systems, Rear Seat Entertainment Systems and More Automotive Electronics
 

·
Registered
Joined
·
87 Posts
I know this may sound like a stupid question but, did you by chance get the internet subscription and not a radio subscription? I have Sirius and the internet subscription is extra.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #6
Thanks for the info! When I got my subscription, I was sitting in the truck to activate it, and i was under a few little trees, so I went to the mall parking lot, and sat there for like a half hour, and still nothing. I will try calling them up again next weekend. If that does not work, I guess I will have to try the new antenna thing. Hey J, did you have to get a new antenna, or could you get your hands on a new one to trouble shoot with?? I wonder if there is a universal antenna that will work to test, or is it manufacturer specific?
 

·
Registered
Joined
·
163 Posts
where did you mount the antenna? Which antenna did you use?
 

·
Registered
Joined
·
98 Posts
Thanks for the info! When I got my subscription, I was sitting in the truck to activate it, and i was under a few little trees, so I went to the mall parking lot, and sat there for like a half hour, and still nothing. I will try calling them up again next weekend. If that does not work, I guess I will have to try the new antenna thing. Hey J, did you have to get a new antenna, or could you get your hands on a new one to trouble shoot with?? I wonder if there is a universal antenna that will work to test, or is it manufacturer specific?
I did not get a new antenna. I had read some talking about the placement of their antenna being important. My antenna is a low profile magnetic antenna mounted on the roof a couple of inches in front of the brake light. I got up there and just messed around with it being sure that is was making good contact with the roof. While is was doing that, I heard the radio come on and I was receiving a signal. I don't know this to be true but some of what I had read implied that the magnetic antenna actually uses the whole roof so a good connection with the roof was important. Maybe that is true since mine started working when I made sure the antenna was making good connection.
 
1 - 8 of 8 Posts
Top