Nissan Titan Forum banner

1 - 20 of 111 Posts

·
Registered
Joined
·
316 Posts
Discussion Starter #1 (Edited)
Hello, I am thinking of replacing my 05 cluster with a 08+ model. Was wondering if this has been done or not?

***UPDATE! We got it figured out! Wiring instructions are posted at the end of the post!***
 

·
Registered
Joined
·
563 Posts
Haven't heard of that yet but people swap in qx56 clusters with no problem. I have one in mine. I bet the 08 cluster would plug right in.
 

·
Registered
Joined
·
316 Posts
Discussion Starter #3
I think I might have to try it, I just hope not to fry anything :)
 

·
Registered
Joined
·
924 Posts
Won't work, the cluster is smaller on the 08 and up, than the 04-07. You could swap in a cluster from a QX56 into your titan, from 04-07 but make sure the cluster is not from a QX56 that had he ICC (intelligent cruise control) cause it will not work.
 

·
Registered
Joined
·
316 Posts
Discussion Starter #5 (Edited)
Won't work, the cluster is smaller on the 08 and up, than the 04-07. You could swap in a cluster from a QX56 into your titan, from 04-07 but make sure the cluster is not from a QX56 that had he ICC (intelligent cruise control) cause it will not work.

Not true, they are the exact same size. I installed it today and it worked. Although it threw a code and went into limp mode as soon as I hit the brake pedal? I looked at the wiring and it looks like pin 17 should be a ground on the 08+ and a brake pedal switch on the 04-07. Ill ground the wire and try it again another day. Also the SLIP light was illuminated which I think I need to swap pin 10 and 18 as this is the wire for the brake fluid. Everything else looked like it worked!

 

·
Registered
Joined
·
364 Posts
is that the original miles on your rig, or is that from another titan?
 

·
Registered
Joined
·
316 Posts
Discussion Starter #7
is that the original miles on your rig, or is that from another titan?
I wish :) This cluster is from a 09' model I believe. The miles stay on the cluster
 

·
Registered
Joined
·
619 Posts
Is it lit up all the way? I thought the newer clusters lit up much brighter than that?

BTW, hat off to you for trying it out! Glad you gave it a shot...
 

·
Registered
Joined
·
557 Posts
Did you ever get the kinks worked out with this?
Not true, they are the exact same size. I installed it today and it worked. Although it threw a code and went into limp mode as soon as I hit the brake pedal? I looked at the wiring and it looks like pin 17 should be a ground on the 08+ and a brake pedal switch on the 04-07. Ill ground the wire and try it again another day. Also the SLIP light was illuminated which I think I need to swap pin 10 and 18 as this is the wire for the brake fluid. Everything else looked like it worked!

 

·
Registered
Joined
·
40 Posts
Subscribing!!!
 

·
Registered
Joined
·
74 Posts
Man there's no way to rewind some of the miles even if you swap clusters my Titan seen beter days
I would like to put a low mileage cluster in the t and make it look new again
 

·
Registered
Joined
·
557 Posts
The white pro 4-x's seem to be dim.

I just swapped the gauges in mine ('11 SL w/ 800 miles) for an '11 pro 4-x with 6 miles and the white is dim even at full brightness.

I'll have to look at it tonight and see how it looks in the dark.

Is it lit up all the way? I thought the newer clusters lit up much brighter than that?

BTW, hat off to you for trying it out! Glad you gave it a shot...
 

·
Registered
Joined
·
619 Posts
The white pro 4-x's seem to be dim.

I just swapped the gauges in mine ('11 SL w/ 800 miles) for an '11 pro 4-x with 6 miles and the white is dim even at full brightness.

I'll have to look at it tonight and see how it looks in the dark.
Maybe you can swap in some brighter LEDs. I put brighter LEDs in my 2007 cluster, here's a picture of it on a cloudy day:
 

·
Registered
Joined
·
619 Posts

·
Registered
Joined
·
557 Posts
I looked at it at night..

First impression - meh.

I usually keep my gauges turned down b/c I don't like the bright light..

However, the white faces in the dark take darkness to a whole new level since they're kind of inverse white.

They'll take some getting used to, but I definitely like them more than I liked the stock '11 gauges.

I wouldn't brighten them.

Maybe you can swap in some brighter LEDs. I put brighter LEDs in my 2007 cluster, here's a picture of it on a cloudy day:
 

·
Registered
Joined
·
316 Posts
Discussion Starter #17
I really like to know if this swap worked!!!
Havent had time to retry it. Only problem is when you touch the brake pedal the car dies down and you get an error code. I looked at both wiring diagrams for the 04-07 and the 08+ and there is one wire coming off the pedal switch I am not sure were it goes. Ill post up here if I ever figure it out.
 
  • Like
Reactions: scottp83

·
Registered
Joined
·
316 Posts
Discussion Starter #18
Does the fuel economy display function?
Not sure, it was cleared. I think I would have to drive on the cluster to find out.
 

·
Registered
Joined
·
619 Posts
Not sure, it was cleared. I think I would have to drive on the cluster to find out.
I'm just curious because I would assume that the ECU would need to support that function. Kinda like how I have "auto" headlight stalk (for my fogs I added) but the ECU would need to be flashed or changed to support that minor function (plus add a sunlight sensor).

I did a full motor swap on my 97 Maxima, I put a 04 Infiniti I35 drivetrain, ECU and cluster in it. The car now has trip computer function, but that data comes from the ECU, not within the cluster.
 

·
Registered
Joined
·
94 Posts
Anything new to report ?? I'd really like to upgrade my cluster....just saw a new Ford interior and man is it nice.
 
1 - 20 of 111 Posts
Top