Nissan Titan Forum banner

1 - 20 of 206 Posts

·
Registered
Joined
·
455 Posts
Discussion Starter #1 (Edited)
Hi All,
I spent close to a hour searching and reading to find answer before posting. There was a wealth of info but I couldnt find any definite answers so here I go:
I have the tick/rattle coming from passenger side glove box/firewall area. It only does it when:
1) after a couple minutes of warmup
2) only when gas is applied, always stops if foot is taken off gas
3) ticking matches rpms (more gas I give, the faster it ticks.

I had my wife drive around while I was laying underneath dash with glove box off with me trying to locate source. I think I came to conclusion that source of tick isnt coming from inside cab.

I know many has had the same problem (identical situations) but has anyone found the cure? Maybe I missed it in the searches but I never found a common cure.
Thanks for any help

Mike
 

·
Registered
Joined
·
88 Posts
There have been lots of theories, but there is no definitive answer for this problem on this site. Solutions have included: replace manifold, replace cat, replace exhaust pipe after cat, retorque the spark plugs, add a ground wire on the engine block, tighten the engine mounting assembly, replace loose heat shields, etc. At least one person for each of the these repairs has stated that it solved their ticking problem. It leads one to believe that there is more than one ticking problem.
 

·
Registered
Joined
·
455 Posts
Discussion Starter #4
I will check the spark plugs. My main problem is my particular dealer is one of the ones that really seem clueless as far as mechanical stuff. Seriously!!! Or really dont care about the "trivial" stuff like rattles and ticks.
So fixing this myself seems like my best hope. I told the GM of dealership that no one will go after a problem like the guy that just laid out 30k plus for the vehicle and he agreed! :huh: In a perfect world, the dealership mechanics would treat our trucks like they just wrote the check themselves.

It appears from searches, some of you guys are lucky enough to have a service department that seems to care about getting things fixed. Man that would be nice.
 

·
Registered
Joined
·
455 Posts
Discussion Starter #6
I edited the first post, forgot to mention that ticking matches rpms as well. More gas= more ticking.
I removed and re-torqued #8 spark plug, didnt help. argh.
 

·
Registered
Joined
·
44 Posts
i fixed mine for good about a month ago
i added a ground wire to the back of the engine block.
you can get a 36" battery cable at discount auto or something
here is a pic

lemme know if it works

Noah
 

·
Registered
Joined
·
88 Posts
Arkman0:

Is the other end connected to the block where the small ground wire is attached? I assume the small ground wire is for some electronic component.
 

·
Registered
Joined
·
44 Posts
yep, just put the bigger wire on the same bolt and tighten it down...
Wolfhound said:
Arkman0:

Is the other end connected to the block where the small ground wire is attached? I assume the small ground wire is for some electronic component.
 

·
Registered
Joined
·
34 Posts
Definitely keep us posted to your progress! I just had my first oil change, and not sure if I just now am noticing it, or it just started, but I have the exact same issue. My first thought was "oh crap... valvetrain's out of whack", but hopefully that's not the case.
 

·
Registered
Joined
·
88 Posts
Just got back from the auto parts store and installed the ground cable. It looks like it worked for me too! I drove around for about an hour and the ticking has not returned. The guys on this forum like Arkman0 and JetTech that come up with this stuff are amazing.

Any theory on why this works, and what was the sound? Some sort of static or arc I assume? The head is already grounded at the front of the engine, so I don't understand why this new ground path solves the problem. I am still in disbelief that my ticking appears to be gone, hopefully for good!
 

·
Registered
Joined
·
44 Posts
all sorts of crazy things happen when you have spark plugs around...
glad it worked!!
we should start a rattle/tick fix thread to checklist all the known ticks/rattles and the known fixes..and make it a stickie.

Noah

Wolfhound said:
Just got back from the auto parts store and installed the ground cable. It looks like it worked for me too! I drove around for about an hour and the ticking has not returned. The guys on this forum like Arkman0 and JetTech that come up with this stuff are amazing.

Any theory on why this works, and what was the sound? Some sort of static or arc I assume? The head is already grounded at the front of the engine, so I don't understand why this new ground path solves the problem. I am still in disbelief that my ticking appears to be gone, hopefully for good!
 

·
Banned
Joined
·
452 Posts
arkman0 said:
i fixed mine for good about a month ago
i added a ground wire to the back of the engine block.
you can get a 36" battery cable at discount auto or something
here is a pic

lemme know if it works

Noah
I must be blind, because I can't see it in the picture?!
 

·
Registered
Joined
·
182 Posts
arkman0 said:
yep, just put the bigger wire on the same bolt and tighten it down...

Noah,

Did you buy a 36" cable with 1/0 gauge terminals at each end and put them over a bolt at each end and just tightened them back down? I assume I am seeing one end just to the left of the fan belt in your pic? Or did you bolt to the battery cable & then the back of block? Thanks

NITEBLITZ
 

·
Registered
Joined
·
204 Posts
Mike Z,
Here is a thread about this issue from a while back. Personally my ticking was the exhaust manifold. The dealer replaced the mainifold/cover/gaskets and the ticking stopped. That was about 2 months ago and the ticking has not come back.

http://www.titantalk.com/forums/showthread.php?t=13570
 

·
Registered
Joined
·
455 Posts
Discussion Starter #19
Update

A big thanks to arkman0!!!!. Since putting on the new grounding wire, I have now put 70 tick free miles on the truck! Amazing. Anyone that is experiencing this ticking -matching rpms, I highly suggest trying this. It only take a few bucks and 15 minutes.

I guess my only question now is it possible that some of these titans were not properly grounded to begin with? Some get the tick and some dont. Weird.

Anyway, the cable looks factory and I am tick FREE!!! :)
 

·
Registered
Joined
·
44 Posts
Awesome!!!!
glad to hear i could help!

MikeZ said:
A big thanks to arkman0!!!!. Since putting on the new grounding wire, I have now put 70 tick free miles on the truck! Amazing. Anyone that is experiencing this ticking -matching rpms, I highly suggest trying this. It only take a few bucks and 15 minutes.

I guess my only question now is it possible that some of these titans were not properly grounded to begin with? Some get the tick and some dont. Weird.

Anyway, the cable looks factory and I am tick FREE!!! :)
 
1 - 20 of 206 Posts
Top