Nissan Titan Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3,921 Posts
Discussion Starter #1 (Edited)
So finally my front end has finally developed the nasty squeaks. I put new Rancho RS9000 on about 2 months ago. Had them adjusted to 6 in the front and 5 in the back. Excellent ride and did good off roading at work on the typical constructions sites. Back in mid October while getting out in the woods and having to take some more serious trails I noticed the front end was squeaking bad when I hit any bump larger than a speed bump. Besides the crappy plastic glides on the leafs chirping like a tweaty bird this noise is scary. Anyhow I adjusted the fronts all the fronts to 9 and it cured most of it but damn it still loud. I lubed every joint under there and nothing has helped. It doesn't do it when just pushing up and down on the front either. I don't think it's the shocks, they ride to good to be wore out with 2000 miles on them. It could be the sway bar bushings or sway bar ends??

Anyone remove that sway bar?? Safely?? I fixing to look for a replacement.

Sorry I had to throw in here 2005 4wd with 124k miles
 

·
Registered
Joined
·
3,921 Posts
Discussion Starter #4
See if the bushings are wore out if not take them out and put some moly-grease on them inside and out. The squeak will go away.

Sorry for the late reply, been busy. Anyways I haven't pulled the sway bar yet, so you say the pushing are replaceable/lubeable??

I will have to crawl back under there and see what I can do. Thanks
 

·
Registered
Joined
·
14,534 Posts
yes the sway bar bushings are replaceable and cheap too
 

·
Registered
Joined
·
3,921 Posts
Discussion Starter #7
Thanks PRJ! Too bad my '05 has 125K miles on it. No complaints. it gets used harder than most street queen lifted and modded trucks.
 
1 - 7 of 7 Posts
Top