Nissan Titan Forum banner

1 - 20 of 27 Posts

·
Banned
Joined
·
2,738 Posts
Discussion Starter #1
Well I'll be the first to admit this is a pretty worthless thread for most, but it may help someone out in the future.

I filled the truck up today and I averaged out 14mpg. Before my alternator was going out. Sometimes it'd whine like a supercharger (sounded REALLY COOL!) but clearly it was "something" going out. Then my volt gauge on the dash would wig out. Go from 13volt to 10 volts. Higher RPM the volts would go back up to 13 range.

Finally Alternator went out, so that had to be replaced. Now I've noticed driving it, getting better MPG! Before I would average 9mpg (city/high combined). Now I'm at 14 city/high combined.

..it is what it is.

:bangit:
 

·
Registered
Joined
·
6,654 Posts
Well I'll be the first to admit this is a pretty worthless thread for most, but it may help someone out in the future.

:bangit:
We wouldn't have expected anything less. :rofl:
 

·
Premium Member
Joined
·
69,811 Posts
And still in a sold truck............
 
  • Like
Reactions: bbomar

·
Banned
Joined
·
2,738 Posts
Discussion Starter #4

·
Registered
Joined
·
6,654 Posts
Ignore List



To add a user to the list, enter their name into the empty text box and click 'Okay'.


I could, but I'm having too much fun :teethmast
 

·
Premium Member
Joined
·
69,811 Posts
:rofl: :rofl: :rofl:
 

·
Banned
Joined
·
27,783 Posts
I sooooo, want to see what you are driving!!!

Post a pic!!!

PLEASE!!!!!!!!!!!! :rofl:
 

·
Premium Member
Joined
·
69,811 Posts
You have to give the buddy that can't afford to pay time to get there, so he can take a pic... remember??
 

·
Registered
Joined
·
779 Posts
sounds like you needed a computer reset and that is what you got with the power removed while changing the alternator.
 

·
Registered
Joined
·
6,654 Posts
I'm pretty sure he needs a lot more than a computer reset.
 
  • Like
Reactions: Arachnid

·
Banned
Joined
·
2,738 Posts
Discussion Starter #12
Nah just normal driving habits. I was thinking if a ECU reset was the reason for the boost in MPG..but can the system get that messed up in a few months to drop the mpg by 5???
 

·
Premium Member
Joined
·
3,556 Posts
Was this the Sasquatch you were driving? I don't believe it! I need proof, pix - no, never mind - the pix are always doctored.:rofl:
 

·
Super Moderator
Joined
·
93,553 Posts
  • Like
Reactions: J.Bahde

·
Registered
Joined
·
2,146 Posts
How did you get 9mpg before? Were you literally flooring it from every stop? I drive my Titan pretty rough and im averaging around 12 or 12.5 city
No offense, but aren't you like 15 years old? And you do enough driving to average out an MPG reading?
 

·
Registered
Joined
·
111 Posts
Im still baffled by my truck. I drive it like an old man, keep the shifts below 2500 all the time, no 4wd use. I drive all city and get 11.4-11.5......I did see 12.0 one time when it was colder up here in Alaska, but its getting warmer now into the 30's and 40's.


So I take my 1st long trip in the Titan towing my 500lb snowmobile in the bed, some gear.. gas etc totalling aprox 800lbs of load. This is on a 600 mile roundtrip, all highway, 2 lane fast moving country roads , at anywhere from 65-80mph. Actually averaged 16.0mpg to my amazement, maybe at 2k miles on the odo its starting to finally breaking in some. Made some trips around town today and was still showing in the 15mpg area......Maybe this beast is startin to loosin up.
 

·
Registered
Joined
·
3,346 Posts
well i have a 6" lift with 35" and im getting 12 mpg to the mile. well i got to admit i have a injen intake but i got 9.5 with out so i dont know how you got 9
 

·
Banned
Joined
·
2,738 Posts
Discussion Starter #18
well i have a 6" lift with 35" and im getting 12 mpg to the mile. well i got to admit i have a injen intake but i got 9.5 with out so i dont know how you got 9
I'm not sure either. About half a year ago I averaged 19mpg highway with a motor and a half in the bed, along with a tranny (out of some Broncos and F150). Then for some reason my mpg just got worse and worse, so I replaced the air filter, checked the plugs and belt. New oil change and checked pressure on all tires. Eventually it bottom out at 9mpg average on each tank I filled up. Either way I'm just glad to get 14mpg until I buy a new truck.

Before my gas guage would hit 3/4 tank around 30-40 miles..last two tanks I get to about 70miles before it hits the 3/4 mark :redblob"
 

·
Registered
Joined
·
108 Posts
I've had averages of 9 mpg and less before. However, that was with my foot in it a lot and using E85.
 
1 - 20 of 27 Posts
Top