Nissan Titan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
hey guys, i been expeirencing some wierd **** with my titan one the freeway, when iam doing 70-80 mph one the freeway and i make kind of a hard long turn i can feel and hear something grinding like the brakes or something, and then my slip light starts flashing, it will do it for about 5-10 second then stop and everything is normal, any help is greatly appriciated.


thanks in advance
tyler, formula-T
 

·
Registered
Joined
·
6,373 Posts
It sounds like a VDC issue, that's the type of sound it makes when it kicks in...BUT we'll never know because you never bothered to let us know anything about you truck except it's a 04' w/69K on it...Shame...
 

·
Premium Member
Joined
·
9,417 Posts
loufish said:
It sounds like a VDC issue, that's the type of sound it makes when it kicks in...BUT we'll never know because you never bothered to let us know anything about you truck except it's a 04' w/69K on it...Shame...
Loufish is right-it sounds like a VDC issue.

Of course, I assume that you didn't have 4WD accidentally engaged....:crying:
 

·
Registered
Joined
·
58 Posts
Discussion Starter #4
its a 2004 cc se 2wd, stupid me, but the vdc buttion works fine, i want to say its doing a burnout :) , and the vdc is kicking in, ii should prolly try that, thanks for the input guys
 

·
Registered
Joined
·
298 Posts
Next time is dose it, quick hit the VDC button. If it goes away you know that’s the problem. Probably a sensor not reading correctly thinking you’re getting wheel slip when your really not…
 
1 - 5 of 5 Posts
Top