Nissan Titan Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
210 Posts
Discussion Starter · #1 ·
Hey guys, I have had my '08 for a few weeks, and any time the right side of the truck hits a pothole or a big bump, there is a squeak in the cab somewhere. It sounds like it is in the back of the cab on the drivers side.

Anyone have this? Anyone know what could be causing it?

I am going to the dealership in a couple of weeks, but just trying to find it, it is driving me nuts!
 

·
Registered
Joined
·
740 Posts
Mrhavasu said:
Do you have the under seat storage bin? If yes, it could be the mounting tabs.

I also have a squeek in my 07 and I do have the underseat storage. I thougt it may be coming from the rear seat backs where they attach to the back of the cab. Never thought about the seat storage. How do you fix that?
 

·
Registered
Joined
·
120 Posts
same here, guys.

at first i thought it was the leaf springs going bad... then, got that checked out... then, thought it was the back roll-down window... and got that checked too. now, i don't know what it is... and just turning up the speakers to drown out the noise.
 

·
Registered
Joined
·
533 Posts
soak the metal hinges on each side of the back seat with silicone. This is cause of the treaded 'chirp' sound.

If you want the dealer to help you replicate, pick a young mechanic (good hearing) and drive around with him (or her) laying down on the back floor and lift the bottom of the seat up. The chirp will stop. Mine would also chirp with someone sitting in the backseat if that person leaned forward (and thereby took pressure off the back portion of the backseat.

hope this helps

white
 

·
Registered
Joined
·
50 Posts
I've gotten a creak lately in my '07, and I think I found it was the driver's seatbelt pullin whatever it is attached to if too tight. I don't remember havin this until I hit 10-12k miles. Other than that, just the normal sqeaks when goin down a bumpy road, but nothin too horrible or chronic.
 

·
Registered
Joined
·
52 Posts
My 06 CC has a creak from the rear drivers side seat back. Creaks right where the seat attaches to the back side of the truck body.
 

·
Registered
Joined
·
19 Posts
. I had the exact same annoying squeak on my factory underseat bin (08.5 LE 4X4). The quickest fix is to apply black electrical tape to each side of the seat bin bracket. As mentioned in previous posts, the squeaking occurs when the metal bin bracket rubs against seat bracket. All you have to do is cover the metal bin bracket on each side of the cab. If you wrap black electrical tape over the bin brackets where they meet the seat brackets then you will silence the squeak. Problem solved.
 

·
Registered
Joined
·
147 Posts
What if the squeek is coming from the underneath side of the truck? Mine does it mostly after the truck is hot, I think it may be a heatshield, but they all look good.
 

·
Registered
Joined
·
71 Posts
Had my truck for about a year now and still can't find the squeak, dealership tightened the suspension, still squeaks, and muffler shop just said it's a truck, it squeaks ... problem is I've owned trucks and this is not a common squeak ... anytime I pull into a drive way or hit a small bump the truck squeaks horribly from underneath(can't pinpoint exactly where, but outside) normally when pulling in from the left. From the right I might get a squeak every now and then but I can replicate the squeak over and over again from the left side with no problems. I went as far as spraying everything that looked like it could squeak with wd40, took about 30-45mins ... and then the squeak was still there ... Good luck in finding yours, this thread may have just motivated me once again to try and find mine today ...
 

·
Registered
Joined
·
740 Posts
Had my truck for about a year now and still can't find the squeak, dealership tightened the suspension, still squeaks, and muffler shop just said it's a truck, it squeaks ... problem is I've owned trucks and this is not a common squeak ... anytime I pull into a drive way or hit a small bump the truck squeaks horribly from underneath(can't pinpoint exactly where, but outside) normally when pulling in from the left. From the right I might get a squeak every now and then but I can replicate the squeak over and over again from the left side with no problems. I went as far as spraying everything that looked like it could squeak with wd40, took about 30-45mins ... and then the squeak was still there ... Good luck in finding yours, this thread may have just motivated me once again to try and find mine today ...
You do not want to use WD 40 for anything under your truck. WD will wash away with water and it is not the best lube for something like that, esp when you get around areas that could get too hot. Try something like a silicone lube made for high heat areas and it will not wash away as easily.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top