Nissan Titan Forum banner
1 - 20 of 34 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
My battery died because I left my gps plugged into the always on socket.(news to me, but now I know) I tried to get a jump and it wont even try to turn over. The battery shows midway charged, lights come on, radio works, but it wont even try. It did at first when I tried to start it originally and now it won't. I checked all the fuses in the dash, and the 2 i could find under the hood. Does anyone have ideas? Did I ruin my starter?

Its a 2008 XE Titan. please help me!
 

·
Registered
Joined
·
5,541 Posts
My battery died because I left my gps plugged into the always on socket.(news to me, but now I know) I tried to get a jump and it wont even try to turn over. The battery shows midway charged, lights come on, radio works, but it wont even try. It did at first when I tried to start it originally and now it won't. I checked all the fuses in the dash, and the 2 i could find under the hood. Does anyone have ideas? Did I ruin my starter?

Its a 2008 XE Titan. please help me!
sometimes midway charged ain't enough. make sure to fully charge the battery. i'm surprised it won't turn over. :confused:

try taking someone else's battery and see if the truck will even start.
 

·
Banned
Joined
·
27,783 Posts
Your battery has ate it!!!

If you're under 36,000, I would call the dealer!!!

Or go buy a real battery that will last more than three years!!

Good Luck!
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #4 ·
I am going to run to walmart and grab a battery to see if thats it. But she won't even growl. That makes me thing starter, becuase it was at least trying earlier. now nothing at all.
 

·
Registered
Joined
·
5,541 Posts
I am going to run to walmart and grab a battery to see if thats it. But she won't even growl.
hope its not to far of a run, cause carrying a battery back is going to be a b!tch... borrow a walmart shopping cart for the run back... :lol:

just see if someone else's truck battery will start your truck before buying one. your battery shouldn't have bit the big one just yet, but it wouldn't be the first time hearing that story of a titan oem battery going to sh!t. mine barely made 3 years.
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #7 ·
So it wasnt the battery. It just clicks and wont turn over. Any other ideas? I saw fuse box behind the one next to the battery. Its back in there. Should I test those fuses? I do not want to start pulling and checking them until I am sure that might help.

Thanks for any more help.
 

·
Registered
Joined
·
5,541 Posts
check the ground cable, make sure its on good and follow to where it attaches to the engine block. make sure there's a solid, tight connection.
 

·
Registered
Joined
·
12,665 Posts
Is an engine supposed to trun over? I mean its bolted down. You might have to take off your motor mount bolts to turn over the motor. But if you do turn it over, all the fluid is going to go the wrong way, and your exhaust is going to be pointing out over the top of the truck. Plus those motors are heavy to turn over.



LOL
 

·
Registered
Joined
·
5,541 Posts
Is an engine supposed to trun over? I mean its bolted down. You might have to take off your motor mount bolts to turn over the motor. But if you do turn it over, all the fluid is going to go the wrong way, and your exhaust is going to be pointing out over the top of the truck. Plus those motors are heavy to turn over.



LOL
i recommend a cherry picker for this sort of task... :teethmast

no but seriously, i have no other clue as to what it might be :confused:

got gas right? :huh:
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #11 ·
Yep. got gas. It just wont even make the rrrrrreeerrreeerrrrr sound. It did earlier today, so i feel like something happened. I guess I gotta get it towed to nissan :-/
 

·
Registered
Joined
·
6,823 Posts
New battery and it's clicking fast means there is a bad connection at the positive or negative battery post or as mentioned at the ground on the engine block.
 

·
Banned
Joined
·
2,738 Posts
I'm confused. Did you throw in a new battery?

My truck started up perfectly fine at taco bell. I drove 1/4 mile down the street and parked at starbucks. Went inside and got a coffee. Came back out, the truck would click, but no turn over. New battery and started right up.
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #14 ·
Yes I did put in a brand new battery. Maybe i did not attach the cables tight enough? But I am pretty sure that's not it. It just does one click. then stops. the lights come on the battery meter goes up to midway.

I can turn on the radio and that works. But no rreereerreee sounds :-/
 

·
Banned
Joined
·
2,738 Posts
Midway as in the middle? That's more than enough cranking power.

Starter may have gone out? Go down below the truck, and hit the starter. Try again. Check those connections.
 

·
Registered
Joined
·
5,541 Posts
Midway as in the middle? That's more than enough cranking power.

Starter may have gone out? Go down below the truck, and hit the starter. Try again. Check those connections.
LMAO, unfortunately you can't just take a screwdriver and nail the starter to get it to maybe fire up. our daamn starter is in the valley of the motor underneath the intake manifold... sucks!!!
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #18 ·
LMAO, unfortunately you can't just take a screwdriver and nail the starter to get it to maybe fire up. our daamn starter is in the valley of the motor underneath the intake manifold... sucks!!!
:crying: I am unemployed at the moment, so no money to really pay someone to fix it. This is so fail!
 

·
Premium Member
Joined
·
72,926 Posts
1 - 20 of 34 Posts
Top