Nissan Titan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I replaced 4 stock speakers (base, NO Rockfords). Those stock speakers were horrible. I've been always happy with stock speakers until I picked up this 08 Titan SE 4x4. well, I thought walmart might have decent speakers since stock headunit won't put out that much power. So I picked up a pair of Pioneer 300w 6x9 4 way speakers for the front and a pair of Sony 270w 6 1/2" for the rear. Rear speaker fitting was kinda tricky. After all, the sound is much better, very clean with no distortion. but still lacks bass. I have Kenwood KAC-9103D mono amp and Rockford power stage 1 sub in my closet. can't wait....

Here's some helpful info that i found on web.
Nissan Titan speaker wiring colors
Front Left + : blue/white
Front Left - : blue/red
Front Right + : white/black
Front Right - : blue/black
Rear Left + : light blue
Rear Left - : blk/yellow
Rear Right + : oange/blue
Rear Right - : red/blue
 

·
Registered
Joined
·
6,373 Posts
Good to know VTTitanVT & BBF, awhile back I had to realize L was Lavender. I never use the word Lavender! I think it was on my Trailer Brake Controller. I'm installing my Kenwood Subs, this helped right on time! :)
 

·
Registered
Joined
·
85 Posts
ok im trying to install a 1200 watt amp, I have no problem with powering the amp, but finding the CORRECT rear speaker wires to connect my line converter to has been very tricky for me! I connected to Black/Yellow and Light Blue wires. it worked for about 2 seconds then the amp cut out. Please help me find the correct wires and where to connect them ( before or after factory sub inder drivers seat) PLEASE HELP!!! AHHHHH :crying:
 
1 - 5 of 5 Posts
Top