Nissan Titan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
121 Posts
Discussion Starter #1
Hello all. I was installing my new HID lights last night and the low beams went in no problem. Then i got the to the fog lights and those were giving me some problems. I ordered the H11 HID lights. they seem to look the same but do not go in and lock in place. I have a 2011 T, anyone know or have any xperience putting these fog lights in? I was told 881's or H11's would work in my truck. Thanks.
 

·
Registered
Joined
·
98 Posts
they are 880's for the fogs, sounds stupid just make sure the tabs line up correctly. They can only go in one way. Just compare the connector to the factory to make sure its the same size
 

·
Registered
Joined
·
102 Posts
I just installed mine it takes a little you have push kinda hard on it and turn one was real easy the other took a good push I turned the wheel so I could get some leverage laying on my back under the truck wasn't working :bangit:
 

·
Registered
Joined
·
121 Posts
Discussion Starter #4
I just installed mine it takes a little you have push kinda hard on it and turn one was real easy the other took a good push I turned the wheel so I could get some leverage laying on my back under the truck wasn't working :bangit:
Did you get the H11 bulbs?
 

·
Registered
Joined
·
3,324 Posts
I have 880's and fit with no problems. I did a friends yukon and the tabs were slightly bigger so I took a razor and shaved the tab on one side and it went in perfectly.
 

·
Registered
Joined
·
121 Posts
Discussion Starter #6
thanks, ill try that.
 
1 - 6 of 6 Posts
Top