Nissan Titan Forum banner
21 - 29 of 29 Posts

·
Registered
Joined
·
2,383 Posts
Mine did that once already in the 2 weeks I've had it! I guess that's the norm for HIDs
 

·
Registered
Joined
·
95 Posts
Has anyone else had experience with these? I know the saying "you get what you paid for", but if these are quality, I would get a couple sets ;)
 

·
Registered
Joined
·
1,090 Posts
Discussion Starter · #23 · (Edited)
Well damn, seeing as how I posted the link I feel bad you guys are having issues with them. I have had mine about 9 months now and they are working great. You may try emailing them with your concerns. They seemed willing to help when I told them my 3400k bulbs were not exactly the same color. I hope your able to get this stuff worked out. If not, see if you can return for a refund.

HIDExtra.com [[email protected]] or [email protected]
 

·
Registered
Joined
·
1,047 Posts
I picked up two sets from these guys on the sale date!!! I got lows 8k and highs are 5k. I know highs were kinda useless but i dont have fogs and if u turn the highs on before u leave so they are heated up and ready to go they turn on real quick if someone is pissing u off or if they think ur running brights but your really not. I have had no problems with mine, the only thing i can say is maybe where you mounted the ballast its to close to the antenna? they have worked great for me so far! The only problem i am having is the right one stays a tad bit more bluer than the left one, idk what the problem is but it isnt really noticable, just to me since i installed them. But if you go with 5k or 6k headlights they should be fine! Also my truck radio has an aftermarket headunit and i use my ipod more than i use the radio but i have not had any problems running radio or with the ipod.


DoyleOil- they are 35watt units. It should say on the ballast and i dont think they sell the 55watt units there, b/c i was going to try and pick some up if they did.
 

·
Registered
Joined
·
313 Posts
I installed a set in my fogs. No problems for me. I just wish I would of bought a set for low's!!
 

·
Registered
Joined
·
102 Posts
Wife got them for me when they were running the sale, 5k for lows and 3k for fogs, both are the slim black matte. Put in the lows but ran out of zip ties for the fogs but so far no issues with the lows, I will have the fogs in this weekend. If you put the ballast on the shelf behind the light housing it fits perfect. Have not had any radio interference or start up problems. You dont need the relay wires but they will pull the power from the battery instead of the electrical system so that may help if you have problems with them powering up.
 

·
Registered
Joined
·
221 Posts
The flicker at startup seems to be no problem, once theyre hot they work fine.

I installed my ballasts on the shelf like everyone else, i may see if I have a wire near the antenna or touching something close. I have heard wrapping them in elecrtical tape sometimes works for this, maybe I will give it a shot.
 

·
Banned
Joined
·
12,740 Posts
w0w pricing is good! Are the kits A/C or D/C, 35w or 55w, analog or digital? Sorry too lazy to check.
Not trying to threadjack but i sell 35w 3-30k A/C Fully Digital H.I.D. kits for $45 shipped w/ 1 yr warranty
 
21 - 29 of 29 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top