Nissan Titan Forum banner
141 - 158 of 158 Posts

·
Registered
Joined
·
2 Posts
works on 2012 Infiniti QX56/QX80

ALL,

just wanted to chime in here

I initially had a P2101 code and i pulled the code myself. searched the internet and ended up here.

i did the steps and immediately noticed a huge difference! i did this procedure on Monday evening and Tuesday i punched it and the back end nearly got away from me! this reset procedure really is worth it. and it works just great on my 2012 qx56.
 

·
Registered
Joined
·
139 Posts
How can I tell if it worked? I saw a video where one guys truck SES light blinked rapidly but mine never did that. Just started truck up and seems to be idling different so I am assuming something did occur?
 

·
Registered
Joined
·
66 Posts
Tried everything else, but this is the one that worked. Thanks!

God Bless John Wayne, The Marine Corps, and Titan Talk!

Edit: Added the "Easy Method" for ECU Reset

The Easy Method:

After experimenting with different timing, and reading posts by other members, I've come up with a condensed method of doing this reset. This method works EVERY time, even w/o a stopwatch. I've used this method successfully a dozen times, or so, now w/o a watch. After a few times, you won't need a watch or instructions. You'll get so darn good at it, you'll find yourself doing it while waiting at a traffic light.

Timing is not as critical with this method...no stop watch needed. Just count in your head...one-one thousand, two-one thousand, etc, or use stop watch. The most critical step is step #3....wait 10 sec, instead of 7.

1. Ignition "ON", count to 3.
2. Depress/Release pedal 5 times...hard and fast.
3. Count to 10 (not 7!) and fully depress pedal
4. Count to 12 (SES should be blinking), release pedal
5. Count to 10, depress pedal
6. Count to 10, release pedal.
7. Turn off ignition, then start engine. Done!
 

·
Registered
Joined
·
73 Posts
Thanks a bunch!!! Very easy procedure when you have great directions. Just changed out a bad O2 sensor and needed a ECU clearing. Worked great...
 

·
Registered
Joined
·
7 Posts
I performed the procedures again, just last weekend. Immediately after the Idle air procedure, it were the same results as before. I turn the key, engine starts but then the idle drops right down to 0 and engine shuts off.



Yes I did, a couple times for the last two months since this issue started.

Worse case scenario, I'll end up with having to visit the dealership and pay the 1-hr labor rate for a 5 min fix on the consult.

I just want the armada ready and trouble free since its what I prefer to drive during the fall/winter seasons.
FYI.
I had a similar problem after ECU reset. The Titan wont idle after ecu reset. The truck would start and the rpms would drop then immediately stall out.

I messaged primov8 and he mentioned that he had to clean his throttle body. So i sat down for an hour with carb cleaner and a rag and cleaned everything.

After re-install, its starting, running and idling fine now. Just wanted to let anyone who has this problem know.
 

·
Registered
Joined
·
1 Posts
Just a quick question if while doing the Throttle Valve Closed Position Learning the plate doesn't work what could that indicate? Thanks.
 

·
Registered
Joined
·
150 Posts
Does this work on 2014 models, and how often should it be done, like say installing a CAI?
 

·
Registered
Joined
·
201 Posts
:popcorn:
 

·
Registered
Joined
·
167 Posts
Many thanks for the great (detailed) instructions RockyMtnTitan. I am bookmarking this thread.

But I am kind of wondering about this comment, "You'll get so darn good at it, you'll find yourself doing it while waiting at a traffic light."

That seems strange to me. I cannot imagine turning the engine off and doing it while I am sitting at a traffic light.

But, hey, maybe that is why some folks sit at the light sooooo long after it turns green.

Here I was, thinking that they were just talking on their cell phone. :wink:
 

·
Registered
Joined
·
1 Posts
quick simple question that I wasn't able to find in my search:
When you have a push button to start the engine, what is exactly done to "turn ignition switch to on" ?
 

·
Premium Member
Joined
·
72,909 Posts
Push the button without your foot on the brake.
 

·
Registered
Joined
·
378 Posts
After 14 years operating this truck I had to perform this procedure today after replacing the starter, intake gaskets, and throttle body cleaning. The starter is a pain in the *** to replace by the way. Anyway, I could never get the "Service Engine Soon" to blink during the procedure. Some timing issue. I used the page out of the service manual because it had a graphic that made it look easy. After the first try it worked. The engine was idling at 1200RPM before the procedure and at 650 after. Attached the page for your viewing pleasure.
 

Attachments

·
Registered
Joined
·
1 Posts
My 07 Titan I bought it drove for 3 days then parked it for 9wks had a cast. the battery died ,bought new one. the idle went racing up and down. took it to my mechanic. And he cant get it to reset idle. Dont know why it wont,hes trying not to take it to dealer,he even talk to Nissan hot line and nothing working.This should not happen just because a battery dies. not happy. any ideas
 

·
Premium Member
Joined
·
72,909 Posts
Unhook the battery overnight and see what happens.
 
141 - 158 of 158 Posts
Top