Nissan Titan Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi all, I picked up a 2005 SE 4x4 King Cab a few months ago. I’m trying to resolve an issue I’m having with the windshield vent actuation. The blower motor and hot/cold blend works fine. The actuator for the floor vent works fine when I cycle through the vent settings. But the main dash vents are stuck open no matter what position I set the vent dial to, and the windshield defog vents never open.

There are a number of videos on YouTube which show replacement of an actuator located sort of behind the stereo, which can be replaced from reaching up from the drivers side pedal area. But some videos depict this as a fix for no hot or cold, and others claim it’s a fix for the vent actuation. Most of them reference a clicking sound, which my truck does not make.

To make things more confusing, the factory service manual suggests there is a separate actuator for just the windshield vent. The “diagram” of the HVAC system is maybe the least helpful technical illustration I’ve ever looked at.

has anyone had my specific issue, and can you point me to which actuator opens the windshield defog vent? Is it the one all the videos show up behind the drivers pedals/stereo? Or is it some other actuator buried in the dash?
 

·
Registered
Joined
·
4,601 Posts
Take a look on page MTC-35 of the factory service manual. You'll see a diagram of the air system, from the firewall side, with the defroster actuator clearly marked on the driver's side of the air box, above the lower actuator which is adjacent to the accelerator pedal, which is for the mode door actuation. My guess is your defroster actuator is either unplugged or dead. It's hard to reach but you might be able to get to it without pulling too much dash.
 
1 - 2 of 2 Posts
Top