Nissan Titan Forum banner

1 - 20 of 29 Posts

·
Registered
Joined
·
865 Posts
Discussion Starter #1
Alright so i'm tryin to figure out whats goin on with the front end(if there even is a prob) maybe i'm just being paranoid lol...when I go over certain kinds of bumps it feels as though something might be a little loose but the thing is I have checked all the bolts/nuts 3 times since the spindle and radflo installation and the first time I checked them they were tight. Anyone have any guess on what's goin on? coil bucket contact? I believe I have the rads set for 3" of lift

like I said maybe i'm just being paranoid and this is completely normal? thanks everyone
 

·
Registered
Joined
·
1,173 Posts
Its hard to say with out riding in it but common things to check are Lower Arm bolts, most people think they are tight enough but really need another good impact hit on them, lower ball joint pinched tight enough. I dont know if you have heim upper arms but I had a jam nut come loose, while the arm cant really back out I could feel the slop in it when I would hit the brakes from a slow roll. Then my last thing would be pressure in your coilovers, I had a weird feeling and clunk after my radflo install and turns out one had no N2 in it. I also just saw your running 37's that much tire can cause a lot of deflection in the upper and lower stock rubber bushings, check your bolts again then it might be normal based on such a large tire.
 

·
Registered
Joined
·
865 Posts
Discussion Starter #3
I will check out the things you mentioned tmr. thanks alot man! I appreciate it!
 

·
Registered
Joined
·
1,339 Posts
and of course goose my $hit sounds exactly like u have said...no idea ive been under there 40 times nothing is loose...i gave up and just count down the day when i see a wheel fly past me and realize its mine :)
 

·
Registered
Joined
·
865 Posts
Discussion Starter #5
and of course goose my $hit sounds exactly like u have said...no idea ive been under there 40 times nothing is loose...i gave up and just count down the day when i see a wheel fly past me and realize its mine :)
hahah wut up man! yea its funny I was asking my friend while we were drivin the other day what he thought it was and he was like idk? so I said oh well atleast when something breaks i'll be able to figure out then! haha :teeth:
 

·
Registered
Joined
·
1,339 Posts
lmao i know everyone who drives with me doesnt hear or feel it...but i can feel it in like the pedal or steering wheel...its just weird feels like every bump is multiplied...maybe its just the stiffer tires and changed angles on the stock suspension components. i hate driving by people who are googlin over my truck and give me the thumbs up or the head nod and all i can think about is the awful klunking and banging that is prol going on outside FML!!
 

·
Registered
Joined
·
865 Posts
Discussion Starter #7
lol well I hope you figure out what's goin on with it. I'm gona take a look at mine tmr. Greg finally emailed me back about my cracked c30s, said he'd send me the middle ones(the cracked ones) but I don't think the two bottom ones come apart?
 

·
Registered
Joined
·
1,339 Posts
i was gonna ask ya what ever happened with the deavers...u'll be happy to know mine are still not on lmao...its too cold and ive been workin way to much ot these days...holidays r here and i still have no $$$
 

·
Registered
Joined
·
865 Posts
Discussion Starter #9
i was gonna ask ya what ever happened with the deavers...u'll be happy to know mine are still not on lmao...its too cold and ive been workin way to much ot these days...holidays r here and i still have no $$$
yea man money always seems tight around the end of the yr huh...and yea what's up with this crazy weather? 90 in CA 60 here in CO where im at and blizzarding in the east?!
 

·
Premium Member
Joined
·
9,417 Posts
Alright so i'm tryin to figure out whats goin on with the front end(if there even is a prob) maybe i'm just being paranoid lol...when I go over certain kinds of bumps it feels as though something might be a little loose but the thing is I have checked all the bolts/nuts 3 times since the spindle and radflo installation and the first time I checked them they were tight. Anyone have any guess on what's goin on? coil bucket contact? I believe I have the rads set for 3" of lift

like I said maybe i'm just being paranoid and this is completely normal? thanks everyone
You're not paranoid.

Besides coil bucket contact, worn out bushings/sway bar end links loose, it could be that the washers from the shocks are not installed correctly. This was the case on my install which allowed the whole assembly to move rather than just the shock itself.

PRG Greg should be able to help as he helped us out!
 

·
Registered
Joined
·
865 Posts
Discussion Starter #11
You're not paranoid.

Besides coil bucket contact, worn out bushings/sway bar end links loose, it could be that the washers from the shocks are not installed correctly. This was the case on my install which allowed the whole assembly to move rather than just the shock itself.

PRG Greg should be able to help as he helped us out!
well I took my sway bar off so thats ruled out lol. Not sure how to tell if I have worn out bushings...truck has 95k on it and i've only really beat on it in the desert a few times. how did you figure out that it was the washers?
 

·
Registered
Joined
·
1,266 Posts
I 2nd the LCA bolts. I had a terrible noise that sounded and felt like something was comming thru the floor board. After much searching and checking and a buddies help we found the LCA bolts moving side-to-side. They are not supposed to move that way at all. I put a breaker bar on 'em and torqued the snot out of them. Noise gone. They have to be freaky scary tight.

Note: I couldn't physically get the bolts to move. I actually laid under the truck(stupid i know) and saw them move when my buddy jabbed the brakes. Its an easy check that won't cost a dime. I think it was like 19mm IIRC. I'm not suggesting the extreme i went to, but just torque them good.

Mine would pop and thump when i just turned the truck sharp or hit the brakes just right. It was annoying as fvck and left me scratching my head for about a month.
 
  • Like
Reactions: GREYG00$E

·
Registered
Joined
·
865 Posts
Discussion Starter #13
I 2nd the LCA bolts. I had a terrible noise that sounded and felt like something was comming thru the floor board. After much searching and checking and a buddies help we found the LCA bolts moving side-to-side. They are not supposed to move that way at all. I put a breaker bar on 'em and torqued the snot out of them. Noise gone. They have to be freaky scary tight.

Note: I couldn't physically get the bolts to move. I actually laid under the truck(stupid i know) and saw them move when my buddy jabbed the brakes. Its an easy check that won't cost a dime. I think it was like 19mm IIRC. I'm not suggesting the extreme i went to, but just torque them good.

Mine would pop and thump when i just turned the truck sharp or hit the brakes just right. It was annoying as fvck and left me scratching my head for about a month.
now that I think of it, before I took it to firestone for an alignment it didn't make that sound. They mess with the lca bolts to align the front end don't they? i'm pretty sure I didn't have that noise before I went to firestone though. The noise kind of sounds like im hitting a flat sheet of wood if you know what I mean. also there are only 2 lca bolts/nuts correct?
 

·
Registered
Joined
·
1,266 Posts
Well there is actually 2 bolts and 2 nuts on each side where it attaches to the frame. These are the ones i'm referring to. Tighten them all. It won't hurt anything at all to snug the crap out of them. That is unless you snap them which takes a quite a bit of force. I had a 1/2" Breaker Bar with a 18" cheater bar on them so you should be good. Just make sure you know your own strength. LOL

And yes if they aligned your truck correctly they had to loosen them and adjust the cam washers. I'd bet money we found your issue.
 
  • Like
Reactions: honda250xtitan

·
Registered
Joined
·
865 Posts
Discussion Starter #15
Well there is actually 2 bolts and 2 nuts on each side where it attaches to the frame. These are the ones i'm referring to. Tighten them all. It won't hurt anything at all to snug the crap out of them. That is unless you snap them which takes a quite a bit of force. I had a 1/2" Breaker Bar with a 18" cheater bar on them so you should be good. Just make sure you know your own strength. LOL

And yes if they aligned your truck correctly they had to loosen them and adjust the cam washers. I'd bet money we found your issue.
I'm goin to tighten these down first thing tmr lol. I will let you know if thats the problem...I think i've actually got underneath the T and started tightening one of the lca bolts and then I was like nahhh it can't be these they're already pretty tight! haha
 

·
Registered
Joined
·
14,135 Posts
Well there is actually 2 bolts and 2 nuts on each side where it attaches to the frame. These are the ones i'm referring to. Tighten them all. It won't hurt anything at all to snug the crap out of them. That is unless you snap them which takes a quite a bit of force. I had a 1/2" Breaker Bar with a 18" cheater bar on them so you should be good. Just make sure you know your own strength. LOL

And yes if they aligned your truck correctly they had to loosen them and adjust the cam washers. I'd bet money we found your issue.
hmm maybe i should go check mine too...
 

·
Registered
Joined
·
909 Posts
My clunk has been driving me nuts for a while. Ive checked everything but the LCAs. Might be a dumb question but do I need to hold the cam bolt head when I tighten the cam nut to keep it from turning?
 

·
Registered
Joined
·
1,266 Posts
My clunk has been driving me nuts for a while. Ive checked everything but the LCAs. Might be a dumb question but do I need to hold the cam bolt head when I tighten the cam nut to keep it from turning?
I didn't and i'm not sure how you would. It shouldn't move because its designed oblong to snug against tabs.

Now i'm not say'n this is the fix-all for everyone's issues but its certainly easy enough to rule out. I tried everyhting before i had my buddy drive over me so-to-speak and located this problem. Noises can be a real b!tch to hunt down. I'm one that won't quit hunting even if it requires replacing parts to see. LOL I had a breaker bar on everything else before hitting these. My Impact(a cheap one) wouldn't torque these LCA's enough.
 

·
Registered
Joined
·
1,339 Posts
they told me my right front upper ball joint was loose when they did my alignment....not really sure if that was the case but i couldnt get it to move or feel loose so i was thinking that was my pop/bang/clunk but nope...might just be the lca's like stated. god i hope so i cant stand the clunk nemore...my truck only has 6k on it shouldnt make any noises lol
 
1 - 20 of 29 Posts
Top