Nissan Titan Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I bought a 2008 Titan that had a busted column shifter (first two pictures). As you can see from the pictures, it was actually broken and held together by tape. I pulled a shifter out of a 2004 in a local salvage yard and installed it yesterday. The manual shift button does not work to turn on the manual shift mode. Otherwise it is fine. I looked at the wires and do not see the wear issues many on this site have discussed.

Does anyone see any problems with the wires? The last three attachments are pictures. Could this be a fuse issue? Any other ideas are welcome. Thanks!
 

Attachments

·
Registered
Joined
·
169 Posts
I bought a 2008 Titan that had a busted column shifter (first two pictures). As you can see from the pictures, it was actually broken and held together by tape. I pulled a shifter out of a 2004 in a local salvage yard and installed it yesterday. The manual shift button does not work to turn on the manual shift mode. Otherwise it is fine. I looked at the wires and do not see the wear issues many on this site have discussed.

Does anyone see any problems with the wires? The last three attachments are pictures. Could this be a fuse issue? Any other ideas are welcome. Thanks!
I'm having a similar issue with my 06,the button will not employ the downshift so basically all Ihave is Drive,just wondering how you repaired yours
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top