Nissan Titan Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
have any of you installed a trailer brake controller in your titan? It's my understanding that all I need to do is plug the wiring harness i ordered with the unit into a very obvious plug on the left side of the dash under the steering wheel, mount the unit, and I'll be good to go. I have 0 experience with this and just want to make sure I am not stupid and it is indeed that simple lolsolitaire.onl/ 9apps.ooo/
 

·
Registered
Joined
·
2,641 Posts
Starting with the basics: you have 12v at the plug? You have a good cable? You have a working unit? Your wiring from cab to plug is good?
 

·
Registered
Joined
·
113 Posts
Starting with the basics: you have 12v at the plug? You have a good cable? You have a working unit? Your wiring from cab to plug is good?
All seams good worked on my 07 6months ago , Has power when first pluged in cycles then display . CH . THEN IF SET PRECONTROLLES it will just display two dots 3/4'' apart also tried plugging into trailer dosent see it
 

·
Registered
Joined
·
2,641 Posts
Well, it sounds like it's either wired wrong or the unit is no longer functioning properly. I don't understand all of your post above, so I'm unable to comment on what "THEN IF SET PRECONTROLLES" means nor what to say about it or how to address it.

My off the cuff guess is, you either have a wiring issue or you have a unit which has failed. I'd start by testing all the wiring, and resetting the unit if your unit allows for a full reset.
 

·
Registered
Joined
·
113 Posts
Have a Teknosha prodigy I keep hearing clicking sounds in the console while activating the manual lever or depress the brake peddel
 

·
Registered
Joined
·
113 Posts
Well, it sounds like it's either wired wrong or the unit is no longer functioning properly. I don't understand all of your post above, so I'm unable to comment on what "THEN IF SET PRECONTROLLES" means nor what to say about it or how to address it.

My off the cuff guess is, you either have a wiring issue or you have a unit which has failed. I'd start by testing all the wiring, and resetting the unit if your unit allows for a full reset.
ive checked all the fuses cant reall tell with the big block one in engine comp. long story short had a console fire no fault the truck and wonder if some wireing is messed up in the console
 

·
Registered
Joined
·
2,641 Posts
Sounds like that could be your problem. It's going to be a pain, but the best path forward is to check all your wiring for continuity and find the disconnect(s).
 

·
Registered
Joined
·
27 Posts
have any of you installed a trailer brake controller in your titan? It's my understanding that all I need to do is plug the wiring harness i ordered with the unit into a very obvious plug on the left side of the dash under the steering wheel, mount the unit, and I'll be good to go. I have 0 experience with this and just want to make sure I am not stupid and it is indeed that simple lolsolitaire.onl/ 9apps.ooo/
What model did you get most them have a intergrated Beale controller in them
 

·
Registered
Joined
·
1 Posts
Installing Brake Controller


I’ve got a 2003 Toyota Tundra with the factory tow package. There is a 7-pin connector in place at the back end and I see a plug under the dash to the right of the steering columne.
Does this mean with the appropriate adapter harness I can plug in a brake controller, mount it and I’ll be done? Or, is additional wiring, grounding, battery connective, etc. required?
If it is just a plug, mount and go I plan to order a controller and harness from Amazon and self install. If more is required I’ll want to have it done.
 

·
Premium Member
Joined
·
69,126 Posts
Wrong forum and country.
 
1 - 17 of 17 Posts
Top