Nissan Titan Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter · #1 ·
Hey guys I know this might be a stupid Q but I'm looking into an intake so thought I'd ask.

I know in the past whenever I put an intake other then the OEM one on my past vehicles a service engine light came on, anybody have this problem with any of the intakes offered on the Titan?? Thanks guys.

Also I'm looking into either the K&N or the Airaid, as I'm kind of in a low budget, any suggestions??
 

·
Registered
Joined
·
217 Posts
I've heard from other members in the past that installing the AFE and S&B intakes makes the service light turn on...S&B came out w/a 3rd generation tube that is suppose to fix that problem..Not sure if it worked..Some popular choices of intakes are Volant, AEM/Fram Boost, & Injen....I am sure other will chime in..
 

·
Super Moderator
Joined
·
93,680 Posts

·
Registered
Joined
·
2,189 Posts
Volant is very good but on the pricy side, theres also a vibration/resonance issue with it, but no codes. AEM is popular too. If your on a budget then the best bang for the buck is throw a K&N drop in filter in your stock airbox and do the airbox mod.
 

·
Registered
Joined
·
9,528 Posts
The light came on for me...but a quick reset was all that was needed (see link in sig)

Also, please don't spend too much on intake...I mean $400+ now I'm seeing for some of these...WTF? It's a tube with a filter on the end...oh and a sheetmetal box if you wanna get fancy for heat shielding....

The HP differences are negligible between the different models.
 

·
Registered
Joined
·
6,823 Posts
S&B had some SES lights come on with the first generation tubes due to a leaking MAF sensor mounting plate. The second generation tubes resolved that problem, but the MAF velocity readings were low and some guys were showing a lean reading at WOT. The final generation 3 tubes sped up the velocity to the MAF sensor and are ok at this point. S&B listened to the customer (us little guys) and made immediate corrections to their product, a rarity nowadays.
 

·
Registered
Joined
·
217 Posts
sudden urge said:
S&B had some SES lights come on with the first generation tubes due to a leaking MAF sensor mounting plate. The second generation tubes resolved that problem, but the MAF velocity readings were low and some guys were showing a lean reading at WOT. The final generation 3 tubes sped up the velocity to the MAF sensor and are ok at this point. S&B listened to the customer (us little guys) and made immediate corrections to their product, a rarity nowadays.
Are you running the 3rd generation tube? If so how is it? Do you know if you are getting a lean mixture reading..I have been contemplating on whether to get the AEM Brute force/Fram boost or the S&B...S&B had some good performance numbers, but was a little concerned with the SES light & lean reading...thanks...
 

·
Registered
Joined
·
6,823 Posts
aldaman said:
Are you running the 3rd generation tube? If so how is it? Do you know if you are getting a lean mixture reading..I have been contemplating on whether to get the AEM Brute force/Fram boost or the S&B...S&B had some good performance numbers, but was a little concerned with the SES light & lean reading...thanks...
I'm running with the GEN 3 tube right now, even though my air fuel ratio was fine with the GEN 2 tube. It appears that the FFV Titans can adjust the A/F more than the non FFV ones. So far, I'm running the same 12.2 ratio with the GEN 3 and performance feels the same. This intake knocked off over 3 tenths in the 1/4 mile for me.
 

·
Registered
Joined
·
170 Posts
I have the K&N FIPK generation II intake.passengers have told me its sounds like a angry bumble bee(heard around 2800 rpm to 3300rpm) and have notice a lot of head turns while at stop lights. Easy to install have to check connections once in awhile seems to vibrate losse.gas mileage has increased some can't complain
 
1 - 10 of 10 Posts
Top