Nissan Titan Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter #1
Posted in a different thread:

So I have a 2011 SV 4x4. couple of months ago I left the hood up on my truck while I was working on it. It rained pretty good while the hood was up before I got it closed and the passenger side engine compartment got wet. Not the entire thing, but from battery back to the IPDM possibly the ECU. I closed the hood when I noticed it and drove it down the driveway. It ran rough for the first 500ft or so but evened out. I drove it every once in a while after that and no issues. Last week after a couple of days of rain or wet days the next day I went out and started it ran fine at first but when I got to the end of our road and stop sign it was idling rough. Once up to speed it ran fine. but anytime I came to a stop the truck had rough idle. It did this for about 20 miles. I stopped at a store came back out and started the truck up and it ran fine.

Fast forward to yesterday. I replaced a wheel hub and went out for a test drive started and ran fine but it had been raining for most of the day I ran it for about 20 min and no issues. Park it, still raining and then temp drops. I go to take truck out and try to start it. It just cranks and cranks and acts like it wants to start but doesn't. Try to start it a couple more times and finally get it started. Its idling rough and I notice OP light on and the temp gauge is pegged to almost the top but rises and falls. It won't blow heat inside but I had it 6 hours before. Run it for a couple but then shut it no change. Thinking either moisture in IDPM or ECU.

What are ya'lls thoughts???
 

·
Registered
Joined
·
11 Posts
My Titan stalled at a red light and luckily not on the belt way . Back in 09 this seems to be a contingency issue with these trucks. It turned out to be the IPDM. They replaced it under warranty at 36000 miles for me one month passed my warranty. The truck will start then hesitate until your battery drains after multiple tries . Sometimes it will start like nothing the. Get you at a parking lot and do it again randomly .
 

·
Registered
Joined
·
11 Posts
My Titan stalled at a red light and luckily not on the belt way . Back in 09 this seems to be a contingency issue with these trucks. It turned out to be the IPDM. They replaced it under warranty at 36000 miles for me one month passed my warranty. The truck will start then hesitate until your battery drains after multiple tries . Sometimes it will start like nothing the. Get you at a parking lot and do it again randomly .
Continuing issue”spellcheck” these trucks have lots of electrical issues just to let you know.
 
1 - 3 of 3 Posts
Top