Nissan Titan Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
New to a Titan ('10 pro4x) of 79 days now, new here & read a sh*t ton of threads on the IPDM.
Sorry to beat a dead horse more but curious as to know if these trucks still have this issue? What causes it?
I bought mine from a small dealer (60 day warranty is up) & of course recently started having rear diff/ vdc lights come on, code for neutral switch/ check engine, various intermittent not starting problems. Truck has 78K for miles.
Found this site searching the web, good info on here- THANKS!!

Luckily I bought 3rd party insurance so had local dealer address the problem & with what I told them/ some diagnostic test just replaced the IPDM last week, extra $220 not out of my pocket. It's now OEM but they said the one on there didn't even have the right part #, it was off by one?? Aftermarket? IDK...
Did notice it didn't have a 30 amp relay for fog light/ ECU to switch (think they were small 15a fuses - as I'd already bought one to try).
Cost me $100 for the deductible + $8 tax.

Like the truck so far- little thing hopefully resolved but not worried.
Any other 'issues' to look out for on the truck is much appreciated...
 

·
Premium Member
Joined
·
20,968 Posts
I believe that Nissan came out with a newer IPDM. That may explain the part number issue. The VDC light could be due to a speed sensor problem.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
OEM #: 284b6-ze03b
The one they took out is: 284b7-ze03b

They said there wasn't an updated one, they'd have put it in I'd think but did see IPDM advertised on eBay for $299- had a different cover also??
IDK, it's running again.
 
1 - 3 of 3 Posts
Top