Nissan Titan Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Our 4x4 Titans have 4 cats..... i have the JBA shortys installed and i wanted to know what i need to do to install the magnaflow 94035's. I dont have the primary cats by the way. Do i need them? What options do i have to have my Titan running at its best.... THX
 

·
Registered
Joined
·
433 Posts
you can put the magna cats in your secondary location and put the 02 sensor behind it. i have dt shorties right now with no headers at all and have my ces light on. so i need to put cats on or do uprev tuning based on what other members have told me
 

·
Registered
Joined
·
801 Posts

·
Registered
Joined
·
34 Posts
I know that mine is not a 4x4 but just 10 min ago I pulled both my o2 sensors behind the primary cats on the manifold and there was no SES light.
 

·
Registered
Joined
·
6,345 Posts
hey did u still get that code error DRTYAZN?
No SES code... The key is to make sure the rear O2 sensor is placed after the HF cat, I placed mine 4" behind the exit of my cats. I've had over 6000 miles since I did the swap and no issues.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #8
ok on magnaflows theres some o2 holes on them already, are u telling me not to put the sensors there? i have to put them further behind?
 

·
Registered
Joined
·
6,345 Posts
ok on magnaflows theres some o2 holes on them already, are u telling me not to put the sensors there? i have to put them further behind?
I have my rear sensors in the MF cat bungs, no codes.
Sounds like you have the MF94053 cats... The O2 sensors go in them, just make sure the cats were installed properly, The O2 bungs should be at the exit end, going to the rear... If they are at the front, that would explain why you are getting codes...
 
1 - 10 of 10 Posts
Top