Nissan Titan Forum banner

21 - 33 of 33 Posts

·
Registered
Joined
·
1,741 Posts
Justintoxicated said:
I don't know, I'm having some issues. There is a noticable clang when I hard brake. When I was pulling out for the test drive there was a loud noise and it sounded like something on my truck broke. I don't know if it was the lift or something else. I have been under the truck in the dark for the past few days and I cannot figure out where the clang is coming from. It is difficult for one person cause someone has to move the truck and come to an abrupt stop, and someone lese can listen to the noise.

Whatever it is it's probably going to be expensive and I am out of warranty, and will need a rental if it need to go in for a week or whatever.

I doubt it's anything that's going to cost you. Most likely something isn't tight enough or something is just making contact with something else when the suspension cycles. If you haven't already, give Greg a call and let him know what it's doing, I'm sure he'll point you in the right direction.
 

·
Registered
Joined
·
3,363 Posts
Discussion Starter #22
Yea Greg suggested i first try tightening the upper arm bolts, I tried to tighten everything I could get at without removing the wheels since all I have is the factory jack...but I mgiht have to pull the tire off this weekend and see if I can figure it out. Problem is I left my tools (socket set anyways) in San Diego when my Banshee broke down last desert trip, so I'm kind of limited right now on what I can do.
 

·
Registered
Joined
·
6,182 Posts

·
Registered
Joined
·
154 Posts
Justintoxicated said:
I don't know, I'm having some issues. There is a noticable clang when I hard brake. When I was pulling out for the test drive there was a loud noise and it sounded like something on my truck broke. I don't know if it was the lift or something else. I have been under the truck in the dark for the past few days and I cannot figure out where the clang is coming from. It is difficult for one person cause someone has to move the truck and come to an abrupt stop, and someone lese can listen to the noise.

Whatever it is it's probably going to be expensive and I am out of warranty, and will need a rental if it need to go in for a week or whatever.
still have you sway bar on? or did you remove that?
try checking that i had the same problem with my endlinks getting loose
lost and bought alot of the bolts that hold the sway bar link to the sway bar
and got tired of buying them so i just took the whole sway bar off
 

·
Registered
Joined
·
3,363 Posts
Discussion Starter #25 (Edited)
beeboyee said:
still have you sway bar on? or did you remove that?
try checking that i had the same problem with my endlinks getting loose
lost and bought alot of the bolts that hold the sway bar link to the sway bar
and got tired of buying them so i just took the whole sway bar off
They looked fine to me.
I did find a loose bumper support bolt while I was under there though, but it was not causinng the problem. I can't seem to find any play in anything, the only thign that looked odd to me was that the tops of the springs rest on the studs that go through the coil bucket. But I'm assuming this is normal since I don't see a way around it.
 

·
Registered
Joined
·
5,541 Posts
Justintoxicated said:
They looked fine to me.
I did find a loose bumper support bolt while I was under there though, but it was not causinng the problem. I can't seem to find any play in anything, the only thign that looked odd to me was that the tops of the springs rest on the studs that go through the coil bucket. But I'm assuming this is normal since I don't see a way around it.
can't you find time to get back over to greg's? my front end and rear end have been repeatedly raped by greg and when everything's been buttoned up i've never heard any unusual/abnormal noises/clangs or such. :lol: i'm sure greg can determine/detect the cause.
 

·
Registered
Joined
·
3,363 Posts
Discussion Starter #27 (Edited)
hooligan said:
can't you find time to get back over to greg's? my front end and rear end have been repeatedly raped by greg and when everything's been buttoned up i've never heard any unusual/abnormal noises/clangs or such. :lol: i'm sure greg can determine/detect the cause.
Yea thats probably my best bet, I don't have time durring the week, too far to drive. it's only been a week though. But I will probably have Greg take a look rather than pull the wheel off this weekend myself. Because say I do find a problem, I won't be able to fix it anyways...

I don't even know if it is the lift itself or not, we heard a loud clang when I pulled out of the driveway after Greg put the lift on though, so more than likely it is some loose linkage and something slipped into place but might not be tight (Although I did my best to check in the dark). But who knows.... maybe the body is ready to fall off the truck, I already had some squeeking on slightly ruff roads, something sounded loose, the dealer would not service it under warranty as they said it is just the body moving around and adjustments are only good for 12k. And now I am out of warranty (I think) might have 100 miles left...
 

·
Registered
Joined
·
3,363 Posts
Discussion Starter #28
Well problem has been solved thanks to Greg.

The problem part was the billet piece that slides into the Uniball (not sure what this is called? A Uniball Sleve? ), it had some play in it, maybe it was cut a bit off. After Greg removed it he discovered it was a Camburg part, so he put a PRG one back in and the problem is gone.

They look almost identical but at least the problem is fixed now. He raised the front a bit higher as well so I' more level now. it looks better and rode home great with no noises coming to an abrupt stop.

Now to go wash this Huge Giant Bird Crap off my hood.....
 

·
Registered
Joined
·
5,541 Posts
Justintoxicated said:
Well problem has been solved thanks to Greg.

The problem part was the billet piece that slides into the Uniball (not sure what this is called? A Uniball Sleve? ), it had some play in it, maybe it was cut a bit off. After Greg removed it he discovered it was a Camburg part, so he put a PRG one back in and the problem is gone.

They look almost identical but at least the problem is fixed now. He raised the front a bit higher as well so I' more level now. it looks better and rode home great with no noises coming to an abrupt stop.

Now to go wash this Huge Giant Bird Crap off my hood.....
good to hear! now you can breathe a big sigh of relief, ehh? :lol: arrghh, Camburg part? culprit again? jzaiden won't be too happy to hear that...:paranoid:
 

·
Registered
Joined
·
3,363 Posts
Discussion Starter #30 (Edited)
hooligan said:
good to hear! now you can breathe a big sigh of relief, ehh? :lol: arrghh, Camburg part? culprit again? jzaiden won't be too happy to hear that...:paranoid:
No idea who that is but what cna I say?

Also got to meet Yellowmantis since he was getting some stuff as well. The PRG sticker went on after I washed the poo off when I got home, think I earned it hah.



 

Attachments

·
Registered
Joined
·
3,363 Posts
Discussion Starter #32
hooligan said:
oh [email protected], those stickers are done already i see! been waiting for those! gonna hook with him hopefully this coming up weekend!

truck looks even better now that its a bit higher!
The PRG one or the Titantalk one? I might have to order another titantalk sticker as I got alot of bubbles when I stuck it on, I'm no pro with stickers :p I have a few extra PRG stickers though. I put them in locations I can't see when looking out the rear view mirror anyways.

Most of the mods on this truck are pretty stealthy including the new lift. I have to admit the lift really completes it, especialy as a 4x4. It should take some abuse but it's only about as tall as a stock ford (at least it seems like it). At this height it's still practicle to put the ATV, toolbox, or other heavy crap in the back without having to hoist stuff up. (Or use a ladder :p)

Off Topic but it's finaly comeing together...Not extensive as many members on this forum but it puts a smile on my face. I plan to keep this truck for many miles. I just hope it feels the same :p

HID's in stock headlights and foglights, and Stereo System installed in stock locations but it is very loud, and good imaging, even the HU looks like nothing special but it's excelent quality. I already know my next mod will be air compressors in the storage compartment. I don't think I will be trading in my 05 anytime soon. My Only Concern is the differentials, although I have not had any problems other than an axle seal leak. If I feel the need for more power I'll just have to get the supercharger, not a tundra, but right now I'm happy with the Stillen single side exhaust and AEM. Everything is a huge improvement over stock, I would assume even over an 08.
 

·
Registered
Joined
·
578 Posts
The pics look great!!! This is the setup I would like to get. I have a 05 KC 4x4
and this was exactly what I was thinking of doing 33's with a mild lift.

Did you put block or add a leaf on the rear?

how much lift on the front and did you use the custom spacer with the SAW?

What kind of mileage are you getting?
right now I get 14-15 in light city traffic
and 17-18 on the highway
 
21 - 33 of 33 Posts
Top