Nissan Titan Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
257 Posts
Discussion Starter · #1 ·
on 05 LE 4x4 (non big tow/non off road)

I'm 100% sure it was the correct kit by my front is now sitting at 38.5" and my rear at 38".

Any thoughts??????
 

·
Registered
Joined
·
257 Posts
Discussion Starter · #4 ·
I did, it is alligned and still 1/2" taller up front.
 

·
Registered
Joined
·
257 Posts
Discussion Starter · #6 ·
you mean front?
 

·
Registered
Joined
·
257 Posts
Discussion Starter · #8 ·
I'll take some later...running stock tire sizes on my truck
 

·
Premium Member
Joined
·
823 Posts
Have you contacted anyone at PRG to discuss your problem and verify you have the wright kit? If you like the kit otherwise you may want to concider getting the 1 inch mini lift for the rear. Very simple to put in, but it sounds like it would solve your problem.
 

·
Registered
Joined
·
257 Posts
Discussion Starter · #10 ·
I measured the spacer and it was 1.2" which is the right kit...thought about the 1" blocks in the rear but gonna hold tight for a little bit. I'll get pics up as soon as I can, it may be dark when I leave work though.
 

·
Registered
Joined
·
257 Posts
Discussion Starter · #12 ·
not gonna "chase" it, just wondering if people had the same experience.
 

·
Registered
Joined
·
6,373 Posts
not gonna "chase" it, just wondering if people had the same experience.
Yeah....It's called production tolerances, many vehs are a little different, and as you drive them they can get even more different...
 

·
Registered
Joined
·
969 Posts
Do you have the helper springs in the rear? They compress the leafs a little. Also if you've had a lot of weight in the back, the leafs might have settled.

Otherwise i see 1" blocks in your future..
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top