Nissan Titan Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
I have noticed that my knob lighting (for heating/cooling, air flow) sometimes works and sometimes not. Has anyone had a similar issue? I am not sure if it is a fuse issue or if it is electrical.
 

·
Premium Member
Joined
·
823 Posts
If it were the fuse more than one light would be out. They generally cover a number of electircal conections. Also once a fuse pops that's it, all connections to it are out period until you replace it. More than likely you have a bulb or wiring problem. Don't worry nothing big. If your not comfortable taking the dash apart to track this down, have your dealer take a look next time it's in the shop. It should be a very minor repair.
 

·
Registered
Joined
·
184 Posts
Try adjusting your dimmer control. Some have said that will resolve the issue.
 

·
Registered
Joined
·
2,032 Posts
Mine does the same thing every now and then. Just turn the dash lights off then back on and the lights that were out should come back on. I dont know the reasoning behind it but that works as a temp fix. :)
 

·
Registered
Joined
·
392 Posts
RckyMtnTitan said:
Mine does the same thing every now and then. Just turn the dash lights off then back on and the lights that were out should come back on. I dont know the reasoning behind it but that works as a temp fix. :)
^^^^DITTO^^^^^
 

·
Registered
Joined
·
146 Posts
The 07 has done this a twice that i know of. I just played w/ the dimmer switch. I really don't see this as a major problem so i haven't taken it in.
 

·
Registered
Joined
·
305 Posts
My TT does this as well. Usually the dimmer switch cause as above. My issue began after unplugging the wires when working in the area. I think the plug being "not perfect" may be related.
 
1 - 8 of 8 Posts
Top