Nissan Titan Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
351 Posts
Discussion Starter #1
I put a new Head Unit into my titan this weekend only to discover that I'm a total moron.

I got a metra kit off ebay and it didn't come with any screws/clips or anything like the manual pointed out (I looked after the fact) just the plastic pieces...doh! So I mounted my Pioneer and got it all ready to get tucked inside when oh, drat, it doesn't stay in place! oh, there's no clips like the old one had. So, I start pulling the 4 old clips off the factory dash piece to put on my new metra. Those things are stuck in pretty good, so after prying 3 loose I get stuck on the last one for at least 10 minutes, eventually it gave and i heard it land...somewhere inside of the gaping hole in the dash. I looked around for half an hour, everywhere in the truck... nowhere to be found. so, now i've got a new head unit that looks like smack because I lost a clip.

Does anyone know where I can find one? I don't want to pay another $30 for another dash kit for just a clip.
 

·
Banned
Joined
·
27,783 Posts
It's in the dash??
Is it metal??
If it is, get one of those telescopic magnetic bolt/nut retrievers.
 

·
Registered
Joined
·
737 Posts
you maybe able to find those metal clips at the chain auto stores like kragens, pepboys, autozone, chief, oreillys, whatever is local to you. they seem to sell fasteners of all sorts from every auto mfr. maybe stop by a local stereo shop to see if they have any leftovers.
 

·
Registered
Joined
·
351 Posts
Discussion Starter #6
Justintoxicated said:
hmmmm, My Kit came with new clips....
ya, I'm still pissed at the ebay seller. The package wasn't sealed, but I doubt if he stole the clips and screws out...who knows though.

Thanks for the tips guys!
 

·
Registered
Joined
·
3,363 Posts
it could also be that I got the OEM bezel as well. I believe I read it attached more securley than the aftermarket and the plugs for the holes are not as noticable but It's been a while since I did mine. It was more expensive though. I have a bunch of extra clips (I lost one too, same thing happened) but I don't have them at my house they are packed away in storage hours away..

I actualy found the missing clip when I removed my carpeting and was messing with wires back there :) it fell out of the center area behind the dash eventualy :)
 

·
Registered
Joined
·
351 Posts
Discussion Starter #8
Justintoxicated said:
it could also be that I got the OEM bezel as well. I believe I read it attached more securley than the aftermarket and the plugs for the holes are not as noticable but It's been a while since I did mine. It was more expensive though. I have a bunch of extra clips (I lost one too, same thing happened) but I don't have them at my house they are packed away in storage hours away..

I actualy found the missing clip when I removed my carpeting and was messing with wires back there :) it fell out of the center area behind the dash eventualy :)
awesome. where did you find the extra clips?
 

·
Registered
Joined
·
3,363 Posts
It was part of the stock HU. But I found it when I removed the carpet in my truck when I pulled the interior out to deaden.
 
1 - 9 of 9 Posts
Top