Nissan Titan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
My New 2018 2wd Titan s now with 65,000 miles has been having several problems are any of you having these problems 1) - the blue tooth only links to my phone haphazardly some times it does many times it doesn't work if I restart the truck 3 time on the third start is will often link up Dealership is saying it's my phone but my wife's 6-year-old Toyota links instantly ALL the time even when she drives into the garage if I'm in the kitchen it will link up so its not my phone! ............... 2)- LOSS OF POWER - the truck seems to throw itself randomly into limited-slip mode on the dry flat surface normal driving conditions but when it does it instantly looses power won't get up over 2000 rpm mostly lingers around 1500 rpm slow acceleration Dealership has replaced the brake sensor 2 times but it's getting worse the limited-slip amber alert, dash light comes on and has been coming on when this happens but, now the brake light stays on after I shut the truck off, & the ABS light is coming on. .... 3) rear window slider lock broke the first time I used it the clip fell apart being held together with a business card now, (door speaker also cracked with just talk radio after the first week but they replaced that)
 

·
Registered
Joined
·
169 Posts
What did the dealer say about the traction or VDC system kicking in? Your truck is still under warranty.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
so far they said it was a brake sensor that they've replaced twice now and it just continues to get worse it the brake sensor replacement has not caused any difference in the power loss.... there is something in that my brake light stays on after I shut the truck off and the ABS light occasionally comes on... the big mystery though is why does the limited-slip warning light come on that actually happens consistently.
 

·
Registered
Joined
·
23 Posts
My New 2018 2wd Titan s now with 65,000 miles has been having several problems are any of you having these problems 1) - the blue tooth only links to my phone haphazardly some times it does many times it doesn't work if I restart the truck 3 time on the third start is will often link up Dealership is saying it's my phone but my wife's 6-year-old Toyota links instantly ALL the time even when she drives into the garage if I'm in the kitchen it will link up so its not my phone! ............... 2)- LOSS OF POWER - the truck seems to throw itself randomly into limited-slip mode on the dry flat surface normal driving conditions but when it does it instantly looses power won't get up over 2000 rpm mostly lingers around 1500 rpm slow acceleration Dealership has replaced the brake sensor 2 times but it's getting worse the limited-slip amber alert, dash light comes on and has been coming on when this happens but, now the brake light stays on after I shut the truck off, & the ABS light is coming on. .... 3) rear window slider lock broke the first time I used it the clip fell apart being held together with a business card now, (door speaker also cracked with just talk radio after the first week but they replaced that)
[/QUOTE


I had a similar problem with my 2017, took it to the dealership it was a problem with the transmission and a software update was all it took, 30 mins later mine was fine. So ask them about a software update. Sounds weird but worked.
 
1 - 4 of 4 Posts
Top