Nissan Titan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
511 Posts
Discussion Starter #1
Just installed quick struts in the front and Monroe OEM shocks in the back. Now the truck rides like a buckboard. It's a $WD but one of the things I liked about it was the nice smooth ride with the factory shocks. Now its very tight and controlled and small undulations in road surface really translate rough into the seating area.

I had just recently replaced the same components on another Nissan car and it turned out great. Really restored the factory ride. Just disappointed and not crazy about reversing all the work I just did on the truck.

I have no choice but to put the factory hardware back on. I really thought I would be getting apples for apples here.
 

·
Registered
Joined
·
171 Posts
shocks take a week or two to soften up. How long have they been on?
 

·
Registered
Joined
·
511 Posts
Discussion Starter #3
maybe 125 miles. they are significantly stiffer than OEM and look to actually level the truck. They did make a Rancho that I would expect to have higher spring rates but that's not what I ordered.
 

·
Registered
Joined
·
14,137 Posts
Did you align it after?
 

·
Registered
Joined
·
511 Posts
Discussion Starter #5
Did you align it after?
Not yet. Since there are no cam type bolts in the installation and no changes were made to any of the connecting suspension parts, nothing really changes, especially with the old struts back on. It will get checked at some point. The truck has 74K on the clock. I just want to be sure there will be no more changes before I commit to an alignment.
 
1 - 5 of 5 Posts
Top