Nissan Titan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
367 Posts
Discussion Starter #1
Has anyone had a problem with rocks/sticks & what not catching on the hard plastic mud flaps when 4 wheeling? I figure if I break one, i'll just take all of them off, but i'm wondering if they're prone to being broken offroad? I can picture crawling over a big rock & the plastic scraping the rock on the way down.
 

·
Registered
Joined
·
12,754 Posts
Bullwinkle said:
Has anyone had a problem with rocks/sticks & what not catching on the hard plastic mud flaps when 4 wheeling? I figure if I break one, i'll just take all of them off, but i'm wondering if they're prone to being broken offroad? I can picture crawling over a big rock & the plastic scraping the rock on the way down.
I would recommend pullling them off.They probably already wore the paint off where they hit. I have bare metal on every panel right where the flap makes a bend. Besides they are so hard, that they will probably bend the fender if you hit something hard enough.
 

·
Premium Member
Joined
·
37,152 Posts
Bullwinkle said:
Has anyone had a problem with rocks/sticks & what not catching on the hard plastic mud flaps when 4 wheeling? I figure if I break one, i'll just take all of them off, but i'm wondering if they're prone to being broken offroad? I can picture crawling over a big rock & the plastic scraping the rock on the way down.
I pulled all four of mine off about a week ago when I got the lift. I see you have an 08, I'd pull them off before the paint either scratches or fades underneath. At first I thought the wheels would throw a lot more up onto my fenders without them, but it really hasn't.
 

·
Registered
Joined
·
674 Posts
I have a 07 and the flaps came off as soon as I got home...I think they look better without them.....looks like a farmers truck with thos things on.
 

·
Registered
Joined
·
12,754 Posts
I wish I had pulled mine off when I got the truck. Now I have to clean off the surface rust, and repaint where they wore the paint off.
 

·
Registered
Joined
·
250 Posts
yeah i think mine are gone its an 07' so lets hope and pray no damage
 
1 - 6 of 6 Posts
Top