Nissan Titan Forum banner

21 - 25 of 25 Posts

·
Premium Member
Joined
·
3,565 Posts
Discussion Starter #22
Well it’s the third day and all is still well so I’ll chalk it up to a glitch somewhere, possibly as suggested it’s related to the pedal commander even though the truck was just idling for about 15 minutes and with no pedal input. I’ll just keep the scan tool in the truck for now.
Thanks for your input on this.

Clint
 

·
Registered
Joined
·
15 Posts
Tonight I was sitting in a parking lot with the truck idling after eating my Chick-fil-a. I put the truck in drive to leave and had zero pedal input, I had thought it stalled so I turned the ignition off and started it and see the check engine light is illuminated and guess I’m in limp mode. I turned it off again and open the door and then close it restart it again and all is well throttle wise but the light was still on but I could drive home normally. I put the scanner on it and got a p2101 throttle actuator code.
I find it interesting that it did this while at an idle not under acceleration.
What says the knowledgeable people here?
I reset the light and will keep an eye on it tomorrow.
The FUNNY part is, the last email I read just before this occurred was one from the Nissan dealer telling me all about this months service specials, go figure. Maybe they were talking to my truck, lol.

Clint
"I put the scanner on it and got a p2101 throttle actuator code. I find it interesting that it did this while at an idle not under acceleration".

Clint , it will do it again in about a month. Mine did it in December and again in January @ around 46, 000 miles. My friend's also did it at the same mileage. Both 2017 models. His ia a SV, mine a SL. It's the throttle assen=bly. Both replaced under warranty but nevertheless a PIA.. Question??? Did this happen shortly after you had purchased gas or filled up? In our cases we both had just gotten gas.
 

·
Premium Member
Joined
·
3,565 Posts
Discussion Starter #24
Today I called the manufacturer for my pedal commander and told the woman what happened, she said to uninstall it and then reinstall it like it’s a new installation and if it occurs again to call back. I asked if it’s a unique situation and she said no it’s not, that it happens sometimes after being used for a while. I told her the truck is still under warranty so it’s not a problem anyway as I’m just trying to figure out if it was the unit or the truck. It’s still one of my favorite additions to the truck.

Clint
 

·
Registered
Joined
·
16 Posts
Tonight I was sitting in a parking lot with the truck idling after eating my Chick-fil-a. I put the truck in drive to leave and had zero pedal input, I had thought it stalled so I turned the ignition off and started it and see the check engine light is illuminated and guess I’m in limp mode. I turned it off again and open the door and then close it restart it again and all is well throttle wise but the light was still on but I could drive home normally. I put the scanner on it and got a p2101 throttle actuator code.
I find it interesting that it did this while at an idle not under acceleration.
What says the knowledgeable people here?
I reset the light and will keep an eye on it tomorrow.
The FUNNY part is, the last email I read just before this occurred was one from the Nissan dealer telling me all about this months service specials, go figure. Maybe they were talking to my truck, lol.

Clint
My Mercedes did that years ago. Limped to an auto parts store. Restarted everything has been good for years now
 
21 - 25 of 25 Posts
Top