Nissan Titan Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
589 Posts
Discussion Starter #1
Ive read numerous posts where people complain about how hot( or should I say lack of heat) the heater in the titan gets and I always thought to myself "man mine gets hot, sometimes too hot." Well now mine blows "luke warm" instead of hot like it used to. I took it to the dealer and they had to keep it all day so I had to rent a car because I cant be without transportation all day. The call me at 5 to say its done. I drop off the rental car and my girlfriend takes me to the dealership. I drive around for about 20 minutes to let it get completely warmed up and what do you know the heater still blows barely warm. They said they replaced the thermostat housing, thermostat, and coolant. Then they bled and refilled the coolant system because there was an air pocket. I drive back immediately after I discovered it still wasnt working correctly and they have a tech come out and check it, he says they are all that way, I call b.s. and ask if they have a titan we can compare against but he said there wasnt any we could check it in. I love this truck and this isnt that big of a deal because it doesnt get that cold in Vegas but the point is it should be working. I also hate the service at the nissan dealerships, they wont even give me a damn loaner car. Sorry for the long rant.
 

·
Premium Member
Joined
·
4,217 Posts
He's full of crap. My truck in New Jersey mid winter gets too hot. Ask him how in your climate it can't get hot.

Clint
 

·
Registered
Joined
·
589 Posts
Discussion Starter #3
Clint said:
He's full of crap. My truck in New Jersey mid winter gets too hot. Ask him how in your climate it can't get hot.

Clint
Oh I know they are full of crap. Last winter I remember it being too hot, I would keep it on full blast just to warm the truck up but I couldnt keep it on full blast because I would almost sweat from it. I am just pissed about the attitude of the dealership, both dealerships ive used in fact. I am also pissed that I am going to have to rent a car again and waste money on that.
 

·
Registered
Joined
·
589 Posts
Discussion Starter #4
Can anyone get a temperature reading with their heater on full blast? I just checked mine and the hottest it would get is 82 degrees and that took about 25 minutes to get to that temp
 

·
Registered
Joined
·
8 Posts
Re: My heater quit blowing hot air! me too!!!

mine just started doing the same thing aboout 4 weeks ago. i hadnt used it all summer and went to use it and is "luke warm". mine is probalby blowing around 80-84 as well.
 

·
Registered
Joined
·
589 Posts
Discussion Starter #6
Re: My heater quit blowing hot air! me too!!!

breezeblocker said:
mine just started doing the same thing aboout 4 weeks ago. i hadnt used it all summer and went to use it and is "luke warm". mine is probalby blowing around 80-84 as well.
Well I checked some other vehicles and they all got up to 130-140 right inside the vent. I finally got the dealer to quit sayings its normal and check it again with me there. It turns out that its the valve that lets the coolant into the heater box, it isnt opening all the way so they ordered a new one and Im waiting for it to come it.
 

·
Registered
Joined
·
201 Posts
good for you! Make them reimburse you for your rental car now.

I can't believe they dont give out loaners, our past cars have been mazda's and even for simple problems they give you a loaner.
 

·
Registered
Joined
·
589 Posts
Discussion Starter #8
cleoent said:
good for you! Make them reimburse you for your rental car now.

I can't believe they dont give out loaners, our past cars have been mazda's and even for simple problems they give you a loaner.
They wont pay for the rental car, they said the only time they ever give out loaners is if it is a safety issue. It only cost me like $32 for the rental so I dont feel like making a big deal out of it
 

·
Registered
Joined
·
8 Posts
good luck on the repair. let me know if it fixes it. :rockon

by the way, today i ran the truck with the radiator cap off in the driveway, in an attempt to bleed the cooling system. i checked it after about 15 minutes and it was very warm. probalby around 100 plus degrees. i let it run for an hour with the cap off and then i topped it off,. will start it tomorrow morning and check it out.
 

·
Registered
Joined
·
589 Posts
Discussion Starter #10
I took my truck to the dealer today and had that coolant valve installed and it fixed the problem, the air is coming out nice and hot again
 

·
Registered
Joined
·
589 Posts
Discussion Starter #11
Ok so the heater was working last night, got up to 130 degrees, this morning is was back to only getting as hot as 85 degrees. I dont know what to do at this point, ive already had to leave it at the dealership 3 times and rent 3 cars.
 

·
Registered
Joined
·
589 Posts
Discussion Starter #12
Final update. It works again! It turned out to be the fan knob control. I took it to a different dealership and they got it right first try. In case anyone ever needs to know what temp the heater should be mine was getting up to 150 degrees on full blast.
 

·
Registered
Joined
·
201 Posts
your post before said it worked and stopped working.

Why dont you update the thread again in a couple days after you're sure it's still working :)
 

·
Registered
Joined
·
589 Posts
Discussion Starter #14
cleoent said:
your post before said it worked and stopped working.

Why dont you update the thread again in a couple days after you're sure it's still working :)
Haha I know, I'm sure that it is fixed this time though.
 

·
Registered
Joined
·
1 Posts
Well I have to join this forum. I bought a '04 Titan Se with the Off Road Package and Tow Package. I have been driving this truck for Two days and love it. Tonight as I am driving my heater blows intermintant hot air. Sometimes its about 100 degrees and others its 70 degrees. I live in New Hampshire and its currently 5 degrees outside with 26 inches of snow in the last 15 days. I cant have a luke warm heater and I know the dealer is going to be a pain in the *** about the replacement. Has anyone else had this issue and is the true fix a Fan Control Knob? Please help.
 
1 - 16 of 16 Posts
Top