Nissan Titan Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
520 Posts
Discussion Starter #1
My Samsung Flight cell phone paired to my 08 Titan worked fine for several months. The system then began to experience a 3 second delay when answering a call. By my 4th hello the person calling would hear hello for the 1st time.
- The Samsung Flight is on the Titan recommended list
- Paired the Flight with a Murano and it operates normally
- Paired another phone with Titan and operation is normal
- Replacement Samsung Flight has same delay

Any help would be appreciated:crying:
 

·
Registered
Joined
·
122 Posts
I'm in the same boat with a few extra problems. If I can remember correctly since day one of pairing my phone (Iphone 3g) to the Titan (2 years ago) I think there has always been a delay when answering an incoming call. The person calling hears the 1st through 3rd hello, by the 4th I finally hear them. No idea what the issue is.

On a side note that was my only issue with the bluetooth since day one. About 6-8months ago the incoming ringer has stopped. All I get is the phone icon popping up on my nav screen and even at times thats delayed 1-3rings for an incoming call.

To fix all the problems I have erased and re-paired my phone through the Titan and the phone. I've checked and rechecked all the settings and still no change. I'm not sure but do you notice a difference in the incoming call delay when answering with your steering wheel controls vs. hitting answer on your actual phone? Try to make sure all your settings are good and erase everything on both ends and try again. I think my iphone is the issue.

Let me not even mention how half the people I talk to hate how it sounds on their end when I use the bluetooth but I think thats common with all hands free car versions.
 

·
Registered
Joined
·
122 Posts
By the way, keep me posted on any findings and fixes.
 
1 - 3 of 3 Posts
Top