Nissan Titan Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Looking for information on how to start a 2009 Nissan Titan that had sat for 3 months without being started, no crank, no start, fully charged battery, no lights or anything coming on when key turned, can not even lock or unlock doors from drivers master buttons only by key & manual locks 27 Dec 2019
 

·
Registered
Joined
·
1,024 Posts
First, make sure the factory immobilizer isn't the cause. There should be a blinking red light on that's visible on top of the dash. If that small light is not on, you've got no power to the system. Check the positive and negative wiring from the battery back to the harness and ground. Check back with what you find.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
First, make sure the factory immobilizer isn't the cause. There should be a blinking red light on that's visible on top of the dash. If that small light is not on, you've got no power to the system. Check the positive and negative wiring from the battery back to the harness and ground. Check back with what you find.
No red light flashing, positive & negative all connected
 

·
Registered
Joined
·
1,024 Posts
If the light isn't on, your Titan simply isn't getting any power. You may have a corroded or broken power or ground wire. I'd check the connections to the IPDM and ECM to make sure it isn't something simple. If you don't find anything there, you may need to go through the harness and contact points step-by-step.
 

·
Registered
Joined
·
1,024 Posts
Also, was there some reason this '09 Titan sat for three months? Was there any mechanical work done on it before then? How many miles?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Also, was there some reason this '09 Titan sat for three months? Was there any mechanical work done on it before then? How many miles?
I am a long haul truck driver, yes, will get back to you about the miles when I get dash connection
 

·
Registered
Joined
·
1,024 Posts
From what you've posted, it sounds like the truck is not getting any power. It sounds like you don't recall what the mileage is. Is this your Titan? Without any more details on it (including vehicle history, past service, problems, etc.), your best bet may be to take it to a dealer.
 
1 - 8 of 8 Posts
Top