Nissan Titan Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter · #1 ·
i bought my titan in October of 2010 and i love it so far, but i noticed the cargo lights and cargo light switch doesn't work, the cargo lights wont turn on when i open the door or when the switch is activated....yet i didn't care until recently when i was out rock climbing when i couldn't find a piece of equipment in the dark.


Anyone have any kind of idea of what could be it, fuse, wiring?
 

·
Premium Member
Joined
·
46,440 Posts
Ummmm...did you check the bulb?
 

·
Registered
Joined
·
1,518 Posts
maybe the fuse.
 

·
Registered
Joined
·
2,063 Posts
Definately the bulb..........or maybe it's the fuse, yeah definately the fuse. Wait, it could be the switch though. Can you restate the problem?:bangit:
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #5 ·
the fuse looks good, i haven't checked the bulbs in top cargo lamp but the ones in the truck bed look fine, are they on a closed circuit? ( if one bulb goes out all of them will go out, kind of like Christmas lights) anyone? its kinda upsetting not knowing where to look or how to fix it hahaha

thanks for your input dudes.
 

·
Registered
Joined
·
8,175 Posts
They are not on a closed circuit, If you have checked the fuse and by checking I mean pulling it out and putting another one in, then it has to be in the switch or the in the wiring. If you have a circuit tester you can check the switch by testing the wire going in and out. Switch is pretty easy to remove, just clips on the backside that need to be squeezed together.
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #7 ·
it was the fuse...i got working lights now!, haha its the little things in life man.
 
1 - 7 of 7 Posts
Top