Nissan Titan Forum banner

1 - 4 of 4 Posts

·
Premium Member
Joined
·
2,640 Posts
Discussion Starter #1
I just bought a Nismo CAI on Ebay. I installed it to the best of my ability, but there were no instructions with the kit. (the buyer stated that he no longer had them in the description) It sounds great now but there is a slight squeaking sound near readline before the shift. I was wondering if anyone else heard such noises and also if anyone had their instructions left over and could maybe scan them in for me???

Thanks
 

·
Registered
Joined
·
22 Posts
Unfortunately I threw my installation sheet away or I'd scan it for you. Not much you could have done wrong in the install though. There are 2 bolts on the fender side...the one closest to the front of the truck should have had a bolt supplied with the intake while the one in the back re-used your stock airbox bolt. Along the bottom inside edge (closest to the engine) there are 5 bolt holes. The intake comes with 1 bolt, 2 flat washers, and 1 stop nut for each of these holes. Just above the location of these holes is another set of holes....these holes are for you to remount your wire harness looms to. Other than that it's just install the intake tube to the connecting hose (to the throttle body) install the intake pipe support and mount the air filter. The intake pipe support is a approx 1" tall rubber gromet with a threaded bolt sticking out either end....this should have come with your CAI along with 2 flat washers and 2 nuts. Insert the gromet throught the hole on the side of the airbox (a little behind and above the opening for the pipe itself) and secure it with one washer and one nut. Then place the support bracket (built into the intake pipe) over the other end of the gromet and secure it with one washer and one nut.....that's it......you're done.....not much to go wrong. Now as for your squeak my nismo CAI also makes a niose right at redline just before it shifts.....I wouldn't call it a squeak though. The first time I heard it it almost sounded to me like the engine had just colaspsed the filter....sucked it flat. It alarmed me to the point that I stopped the truck and got out and visibly inspected the filter....all was well. I've since concluded that this is just a nomal noise made by this CAI since mine runs great and I've had absolutely no issues with it. Hope this helps. Enjoy the mod! Brian

:D
 

·
Registered
Joined
·
5,541 Posts
my AEM used to whistle all the time but has since gone silent. i kinda miss the turbo-like whistle of the intake. i wonder why it was there and now its gone?
 

·
Premium Member
Joined
·
2,640 Posts
Discussion Starter #4
Thanks for all the info!
 
1 - 4 of 4 Posts
Top