Nissan Titan Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
1,774 Posts
Discussion Starter #1
couldnt get my left one to work so i put the stockers back in.. i am over the hassle of those things...
 

·
Registered
Joined
·
1,774 Posts
Discussion Starter #3
yea i am just frustrated right now :crying: im gonna take apart the one that does not work and see i i can get it to work..
 

·
Registered
Joined
·
2,311 Posts
what kind of kit did you buy?
 

·
Registered
Joined
·
2,311 Posts

·
Registered
Joined
·
1,774 Posts
Discussion Starter #7
yeah? i dont know if i will buy another set.. it seems a lot of people have an issue with one going out..
 

·
Registered
Joined
·
1,474 Posts
I had an issue with one going out. I would move the wires around and it would work again until I hit the next big bump. I got tired of that and took all the connections apart, added dielectric grease to the plugs, and taped all the connections together so they couldn't move. I also secured the wires so they couldn't bounce around anymore. I haven't had an issue since.

Good luck.
 

·
Registered
Joined
·
2,311 Posts
Yea guys, you can't buy a cheap kit. I installed mine. Went offroading and shook the **** out of my truck. And they both still lit up.
 

·
Registered
Joined
·
1,774 Posts
Discussion Starter #11
im gonna go take pics of the kit and post them... the connectors are actually pretty nice... brb
 

·
Registered
Joined
·
1,774 Posts
Discussion Starter #13
there is a little blue LED light on the ballast that indicates its working so i dont know.... maybe i will try the grease idea
 

·
Registered
Joined
·
1,474 Posts
etalian2005 said:
Yea guys, you can't buy a cheap kit. I installed mine. Went offroading and shook the **** out of my truck. And they both still lit up.
Unless you spent a couple grand on the kit, you went cheap.
 

·
Registered
Joined
·
334 Posts
anyone have the $75 shipped kits on ebay?
 

·
Registered
Joined
·
9,480 Posts
tre5 said:
anyone have the $75 shipped kits on ebay?
I've got a kit off Ebay for $130 over a year ago, and still haven't had any problems with it. That is with a fair bit of off-roading, a lot of wash board gravel roads etc. Maybe I just lucked out so far?
 

·
Registered
Joined
·
2,063 Posts
Treebasher said:
Unless you spent a couple grand on the kit, you went cheap.
What's the usual price on the HID's? I spent about $350.00 for my highs and lows and haven't had a problem with them since (knock on wood). I'm looking to get some to replace my fogs, any recommendations?
 

·
Registered
Joined
·
1,039 Posts
I good set of HID generally will set you back around $300. Of course you can piece together name brand parts and make yourself a used one a bit cheaper.

I have the $100 China HID lights in my truck. The worked great for about a year, then one started to flicker, and finally that one wouldn't turn on. I bought the"upgraded" harness which wires them directly to the battery about 2 months back, and they've been workin well since. If I run into another problem the halogens will be going back in.

-Cyrus
 
1 - 20 of 22 Posts
Top