Nissan Titan Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
06 Titan 5.6L

No codes.

Replaced both knock sensors from previous week.

Tried a new MAF Sensor today.

Possible IPDM ??

Symptoms
hickups, spits and sputters when rolling into throttle hard.
 

·
Registered
Joined
·
2,942 Posts
Got an oiled air filter?
 

·
Registered
Joined
·
355 Posts
How long has it been doing it? Maybe bad gas? I'd dump a bottle or two of Heet in there just in case you got water in the tank.
 

·
Registered
Joined
·
14,137 Posts
you wouldn't be the first 06 to lose a fuel pump. maybe get it pressure checked?
 

·
Registered
Joined
·
355 Posts
Good to hear! Thanks for posting the results. It'll help others with similar problems in the future.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Loaded my enclosed on the back of the truck today. Unfortunately truck messed up under load.
Broke down and replaced the IPDM module tonight. Fingers crossed this works.
Almost wondering now transmission issue?

Just to mention what the truck is doing
At Hwy speed 80/100kmh, putting the throttle right down to the floor rpm climbs to 6k or so (caps at 6500) engine than hick ups.

My bully dog tuner says that the engine load at idle is 25 to 29 percent.
With nothing running.
What does everyone show on there's?
 

·
Registered
Joined
·
14,137 Posts
Get the fuel pump pressure checked.
 

·
Registered
Joined
·
170 Posts
Loaded my enclosed on the back of the truck today. Unfortunately truck messed up under load.
Broke down and replaced the IPDM module tonight. Fingers crossed this works.
Almost wondering now transmission issue?

Just to mention what the truck is doing
At Hwy speed 80/100kmh, putting the throttle right down to the floor rpm climbs to 6k or so (caps at 6500) engine than hick ups.

My bully dog tuner says that the engine load at idle is 25 to 29 percent.
With nothing running.
What does everyone show on there's?
Buy a walbro fuel pump.
 
1 - 10 of 10 Posts
Top