Nissan Titan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
107 Posts
Discussion Starter #1
Hey guys, was hoping for a little direction.

I have a 2005 Nissan Titan crew cab 4x4. It just rolled 133,000 today and runs like a champ. I've owned it for just over a year and it just started doing this. Not every time, but some days I get in my truck and turn the key and it just doesn't start. Doesn't click or anything. Just cuts power until I turn the key back to the off position. Then if I turn the wheel one way or another it usually starts no issue. Sometimes I have to do it two or three times but it always starts. I read starters go out but I feel like it isn't the starter because turning the wheel generally helps.

Any direction appreciated.
 

·
Registered
Joined
·
107 Posts
Discussion Starter #2
Oh and just to clarify, it's done this for about 4 months or so, I cleaned the battery cables really well and put a anti corode on it. Didn't change. But one day it just didn't do it for like a month or two, now it started again so that's what's got me chasing it. So I guess intermittent because it doesn't do it every time I drive it. Just when it wants lol
 

·
Premium Member
Joined
·
141,094 Posts
I would begin with a visual inspection under the dash.
Look at the steering column and for things that may be rubbing on it: especially items such as wiring from the ignition switch. You may have a chafed wire.
 

·
Registered
Joined
·
107 Posts
Discussion Starter #4
I would begin with a visual inspection under the dash.
Look at the steering column and for things that may be rubbing on it: especially items such as wiring from the ignition switch. You may have a chafed wire.

IDK why I didn't think about that lol. Im gonna check it out today hopefully. Thank you
 
1 - 4 of 4 Posts
Top