Nissan Titan Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1 (Edited)
Sooo,

I hate to bring this up but I haven't found any post or threads with solutions to my symptoms...

I have an 04 KC, 144,00 miles, 4X4, no mods.

The other day I was driving and out of nowhere my truck started losing power and I wasn't able to accelerate past 40 mph, I was on the freeway when this happened and 30 miles from home. So I throw my hazards on and put-put my way back home. By the time I get home my check engine light was on (obviously), my engine OIL light came on, and my coolant temp was allll the way up...happy day.

I changed my spark plugs and it still ran like crap. I know the exhaust manifold is leaking as well, you can hear it AND smell it. I took it to the dealership, they said my spark plugs were the issue? I told them I literally just replaced them. They said I HAD to use platinum tip plugs and not iridium...didn't make sense because I've been running NGK iridiums for YEARS! So when I get done there and pickup the truck the 'technician' said the truck was running much better and you couldn't feel the misfire as bad. The guy who helped me said that one of the injectors had popped out? I actually originally took the truck in for recall work-ipdm and condenser fan, but then this happened.

So I drive the truck off the lot and immediately it runs EXACTLY the same way it had before ?. Ya, his service tech sucks. I call mr. Ben back and tell him what's going on. He acted surprised. He seemed like a nice guy but I had the feeling he didn't want to deal with this anymore. I paid $203 for them to change plugs, give me a diagnosis and fix my rough running. He said to bring my truck in on Monday...it's my only mode of transportation, so I guess Uber and Lyft for a whole week ?.

My question is-has anyone else had these problems? Would the exhaust leak cause the 02 sensor to give bad readings to the ECU and cause the misfires? Could it be a bad fuel pump? Maybe all the coil packs need replacing? The fuel injectors are bad? I've already ordered a new cat/manifold and will be install it myself, I can't afford to pay someone $1200 to do it. I have already replaced the passenger manifold/cat, it was a pain in the A$$, especially by yourself. Any suggests, comments, input are welcome.

AGAIN-I have searched many posts/threads/forums and have not found any solutions! So please don't 'bump' this...
 

·
Vendor
Joined
·
7,921 Posts
I bet you have a clogged cat from a cracked manifold. This happens all the time and when the manifolds crack the tune is out which causes the truck to run rich causing the cats to fail. Usually the truck will not accelerate past 40 or 2800 RPMS exactly what your saying. The P0420 is a cat insuffency code. Time for the Cajun Stage 1 package to FIX the problem. Replacing with manifolds no matter what make is a bandaid fix. Misfire codes can happen as well. Cajun Bpipes | shreveport, LA 71129
 

·
Registered
Joined
·
2,429 Posts
I hope the oil light was a fluke, because if it isn't then chances are your engine is already burning it....most likely resulting from those cracked manifolds.
I would do a compression and leak down test before sinking another dime into that engine.

If your engine is OK, hit up the guys at Cajun tuning and fix it right!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Unfortunately I can't afford anything like that right now...I have a new cat/manifold on the way and I'm not running my truck till it gets here(Thursday). So till then I'll be taking the city bus as my truck is my only mode of transportation..
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Oh no! ? I hope I'm not toasting the engine...that would be the WORST. I have to take it back to Nissan on Monday, I hope they don't ruin my engine anymore by running tests. They already charged me $70 for their spark plugs thinking it would fix the problem and obviously it didn't. So I'm gonna take out the spark plugs, put mine back in and demand a refund and tell them that if they hurt my engine anymore from running diagnostics and tests that THEY will be liable for a new engine.
 

·
Registered
Joined
·
8 Posts
That sounds exactly what my truck started doing a month ago. I spent a lot of cash chasing a problem to find out it was a clogged up cat due to a cracked manifold. I just placed my order with Cajun this week and hope to have it up and going again soon. If you have already made it to cogging up a cat it wont be long before it gets burned up and your engine eats the remains. You don't want that man. The stage 1 system from Cajun runs around $1500 but I spent more than that at the dealership not fixing the problem and if all that junk makes it back into the engine you can bet it'll cost a lot more. I feel like its worth taking the hit once and be done with it.
BTW thanks for the awesome customer service from Cajun B-Pipes!
 

·
Registered
Joined
·
1 Posts
My 05 had a cracked exhaust manifold, and I got that welded, now I'm getting a p0300 and the o2 codes. Changed out bank 2, the spark plugs, coils, cleaned the throttle, and added fuel injection cleaner. Runs a bit smoother but still rough and code's are still present. Anyone got any ideas
 
1 - 8 of 8 Posts
Top