Nissan Titan Forum banner

1 - 15 of 15 Posts

·
Registered
2020 Baja Storm Pro 4X
Joined
·
41 Posts
Discussion Starter #1
So yesterday I got a CE light before hauling some stuff for work. Three separate trips, all had CE light on. I got notifications via email from Nissan Connect as well. On the trip to the dealer after work, it turns off! lol

I pulled the codes and it shows P26A3 stored. Shows distance driven with code and all that. I called dealer and they are letting me bring it in today and giving me a car. I will post back whatever I find out.

Anyone else dealing with this code on 2020 truck?
 

·
Registered
Joined
·
193 Posts
I remember a post a few years back about this on a 2017. I never saw an update but it happened on a few 2017s. The passenger side coolant bypass valve was what the code indicated. Maybe just a premature failure?
 
  • Like
Reactions: busemans

·
Registered
2020 Baja Storm Pro 4X
Joined
·
41 Posts
Discussion Starter #3
Actually, I found that thread and saw no update later on. I will be sure to post an update later. Maybe it's sticking or something. Who knows? This dealer has been pretty awesome about fixing stuff on this truck, my Murano before and our Maxima.
 

·
Registered
2020 Baja Storm Pro 4X
Joined
·
41 Posts
Discussion Starter #4
So I got the truck back last night. They replaced the engine/coolant bypass valve I think. I left the paper at home and I cannot remember the exact part. Other than my truck smelling like waffle syrup outside when it warms up (they made a coolant mess all over the engine :mad:), it seems fine.
 

·
Registered
Joined
·
329 Posts
So I got the truck back last night. They replaced the engine/coolant bypass valve I think. I left the paper at home and I cannot remember the exact part. Other than my truck smelling like waffle syrup outside when it warms up (they made a coolant mess all over the engine :mad:), it seems fine.
Build date of your rig?
 

·
Registered
Joined
·
1,233 Posts
Same on mine.. The pre covid build....

I’m taking mine in next week for the tire recall, tail light recall, and wire harness recall...

I'm starting to feel like a Ram owner!!! Lol...
 

·
Registered
2020 Baja Storm Pro 4X
Joined
·
41 Posts
Discussion Starter #9
Yeah, that blows for sure. At least they are fixing them up pretty quick. I had a few recalls on my Tundra before as well as a headlight housing that had to be replaced and problems with the emissions system after about 5 years. Nothing is without a few problems. At least I am covered for quite a while longer!
 

·
Registered
Joined
·
185 Posts
Same on mine.. The pre covid build....

I’m taking mine in next week for the tire recall, tail light recall, and wire harness recall...

I'm starting to feel like a Ram owner!!! Lol...
Build date on mine is 1/20 and I just took it in yesterday for the same 3 recalls. Just picked it up a few minutes ago, the tires were fine but the tail lights were both replaced and the wiring harness did require the repair. When I dropped it off I complained about the issues I've been having with my truck "hesitating" to accelerate from a near-stop. Service advisor seemed to think the harness repair may help. We'll see if it does.

550671
 

·
Registered
2020 Baja Storm Pro 4X
Joined
·
41 Posts
Discussion Starter #11
Mine does that hesitation too sometimes. The last time I had it in for the harness recall, I asked them to check if there were any code updates for the ecm or the tcm. I drove a ‘21 Titan as a loaner and it drove so much better than mine. They told me it was because mine was a P4X. LOL Once I accelerated from a quick stop, got nothing and then it slammed into gear, barked the tires and took off. It was odd.
 

·
Registered
Joined
·
1,233 Posts
Mine does that hesitation too sometimes. The last time I had it in for the harness recall, I asked them to check if there were any code updates for the ecm or the tcm. I drove a ‘21 Titan as a loaner and it drove so much better than mine. They told me it was because mine was a P4X. LOL Once I accelerated from a quick stop, got nothing and then it slammed into gear, barked the tires and took off. It was odd.
Funny u say.. my 17’ SL had bad throttle lag and delay that was fixed by a Pedal Commander.

When I got my 19’ the throttle response was spot on.. so much so I sold the Pedal Commander.

My 20’ is almost as bad as my 17’ SL... And even worse Pedal Commander will bot work due to my truck having intelligent cruise control...
 

·
Registered
Joined
·
185 Posts
My 20’ is almost as bad as my 17’ SL... And even worse Pedal Commander will bot work due to my truck having intelligent cruise control...
My '17 had some throttle lag. I was thinking of buying a pedal commander based on feedback from this forum, but instead I traded it for my current 2020. My 2020 definitely has a worse throttle than my old '17 did, I was thinking a pedal commander was in my future for sure but I didn't realize they aren't compatible with adaptive cruise. Ugh. Hopefully the harness repair actually does help, because I'm getting pretty frustrated with it otherwise.
 

·
Registered
Joined
·
1,233 Posts
My '17 had some throttle lag. I was thinking of buying a pedal commander based on feedback from this forum, but instead I traded it for my current 2020. My 2020 definitely has a worse throttle than my old '17 did, I was thinking a pedal commander was in my future for sure but I didn't realize they aren't compatible with adaptive cruise. Ugh. Hopefully the harness repair actually does help, because I'm getting pretty frustrated with it otherwise.
I found some other throttle control brands that seem to work with the adaptive cruise..

I will look at the iDrive since folks seem to like it as much as Pedal Commander...
 

·
Registered
2020 Baja Storm Pro 4X
Joined
·
41 Posts
Discussion Starter #15
If there is something that might work, I would be inclined to try it. I will check into it as well.
 
1 - 15 of 15 Posts
Top