Nissan Titan Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a 2008 nissan titan, runs great, until I try to floor it, basically anything over 2500 ram or flooring it. Truck starts to almost feels like avapor lock or governor and even has backfired, and now has started smoking so during episode bad?? I've tried all new plugs, all new coil packs, mechanic told me the injectors are all proper and compression check was ok?? It the truck does have aftermarket kNm filter as I've heard comments about it. The truck came with the LED brake lights as I have read that they also cause issues, I don't see how that much but then Again I'm not to intelligent when it comes to newer trucks, I have no clue but can not afford to keep buying parts and guess I'm gonna have to sell it and really don't want too.....
 

·
Registered
Joined
·
4,619 Posts
Could be clogged cats. Could be bad fuel pump. Is it throwing any codes? Do you have an exhaust leak? Have you checked the fuel pressure at the rail under load?
 

·
Premium Member
2013 Nissan Titan pro 4x
Joined
·
396 Posts
I have a 2008 nissan titan, runs great, until I try to floor it, basically anything over 2500 ram or flooring it. Truck starts to almost feels like avapor lock or governor and even has backfired, and now has started smoking so during episode bad?? I've tried all new plugs, all new coil packs, mechanic told me the injectors are all proper and compression check was ok?? It the truck does have aftermarket kNm filter as I've heard comments about it. The truck came with the LED brake lights as I have read that they also cause issues, I don't see how that much but then Again I'm not to intelligent when it comes to newer trucks, I have no clue but can not afford to keep buying parts and guess I'm gonna have to sell it and really don't want too.....
clean and or change maf sensor and get rid of any oil covered air filters
had similar symptoms doesnt always throw a code i cleaned my sensor changed to dry filter and reset ecu
and ran normal again
 

·
Premium Member
2013 Nissan Titan pro 4x
Joined
·
396 Posts
clean and or change maf sensor and get rid of any oil covered air filters
had similar symptoms doesnt always throw a code i cleaned my sensor changed to dry filter and reset ecu
and ran normal again
also check your two pcv valves can cause stumble on hard acceleration if stuck
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Could be clogged cats. Could be bad fuel pump. Is it throwing any codes? Do you have an exhaust leak? Have you checked the fuel pressure at the rail under load?
Thank you hit
Could be clogged cats. Could be bad fuel pump. Is it throwing any codes? Do you have an exhaust leak? Have you checked the fuel pressure at the rail under load?
Thank you!! Yes on the codes it is saying multiple
I have a 2008 nissan titan, runs great, until I try to floor it, basically anything over 2500 ram or flooring it. Truck starts to almost feels like avapor lock or governor and even has backfired, and now has started smoking so during episode bad?? I've tried all new plugs, all new coil packs, mechanic told me the injectors are all proper and compression check was ok?? It the truck does have aftermarket kNm filter as I've heard comments about it. The truck came with the LED brake lights as I have read that they also cause issues, I don't see how that much but then Again I'm not to intelligent when it comes to newer trucks, I have no clue but can not afford to keep buying parts and guess I'm gonna have to sell it and really don't want too.....

I want to say, THANK YOU to each of you for responding!! I just don't have it like that " drop it at the dealer" kinda bank roll so, everyone who shared your knowledge, THANK YOU! I used a Lil bit of advice from each post. I had a guy message he and suggest unhooking the led brake lights system ( I didn't think it would cause all of this but tried it as he suggested) no luck. I bought a can of starting fluid and sprayed my hoses, found two major leaks on air flow vacuum lines. Replaced those and the po300 code ( multiple cylinder misfire) code was cleared, no more flashing check engine light and no blue smoke everywhere. Then the "slip" light come on and smells like rotten eggs so bad from exhaust. I seen another thread on here of peeps sharing and a video attached and EXACT same issues, same year, and the code this time read "cat1" however the post suggested that I examine my exausht system, passger side, three quarters way back.....I was shocked, exactly as they shared my exausht had huge whole and crack in same spot as author of the post too. I did see some melted wires above the broken muffler as they shared also. So, ran out of daylight but first thing in the morning, I'm gonna troubleshoot and try to splice and repair. I'll update later.............
s area and fix to the best of my ability and liquid b
 

·
Registered
2017 titan sv 4x4 with tech, convinience, tow, navigation, and Texas packages
Joined
·
4,344 Posts
i hope you are able to get everything fixed and up and running.
 

·
Premium Member
2013 Nissan Titan pro 4x
Joined
·
396 Posts
Thank you hit

Thank you!! Yes on the codes it is saying multiple



I want to say, THANK YOU to each of you for responding!! I just don't have it like that " drop it at the dealer" kinda bank roll so, everyone who shared your knowledge, THANK YOU! I used a Lil bit of advice from each post. I had a guy message he and suggest unhooking the led brake lights system ( I didn't think it would cause all of this but tried it as he suggested) no luck. I bought a can of starting fluid and sprayed my hoses, found two major leaks on air flow vacuum lines. Replaced those and the po300 code ( multiple cylinder misfire) code was cleared, no more flashing check engine light and no blue smoke everywhere. Then the "slip" light come on and smells like rotten eggs so bad from exhaust. I seen another thread on here of peeps sharing and a video attached and EXACT same issues, same year, and the code this time read "cat1" however the post suggested that I examine my exausht system, passger side, three quarters way back.....I was shocked, exactly as they shared my exausht had huge whole and crack in same spot as author of the post too. I did see some melted wires above the broken muffler as they shared also. So, ran out of daylight but first thing in the morning, I'm gonna troubleshoot and try to splice and repair. I'll update later.............
s area and fix to the best of my ability and liquid b
Glad to hear your on the right trail
I always try to get as much info as possible too
So many similar symptoms for different issues
 

·
Registered
Joined
·
10 Posts
I have a 2008 nissan titan, runs great, until I try to floor it, basically anything over 2500 ram or flooring it. Truck starts to almost feels like avapor lock or governor and even has backfired, and now has started smoking so during episode bad?? I've tried all new plugs, all new coil packs, mechanic told me the injectors are all proper and compression check was ok?? It the truck does have aftermarket kNm filter as I've heard comments about it. The truck came with the LED brake lights as I have read that they also cause issues, I don't see how that much but then Again I'm not to intelligent when it comes to newer trucks, I have no clue but can not afford to keep buying parts and guess I'm gonna have to sell it and really don't want too.....
 
1 - 10 of 10 Posts
Top