Nissan Titan Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Yes I know, this a dead horse. 2004 Titan LE 4x4 Crew Cab. My right front is popping only when accelerating from a stop. It's clearly metal and only front right, and I can feel it in the floor board. I have made and installed the spacers for the lower control arm, new sway bar bushings, new links, new struts. I have checked motor mounts and trans mount all are newer and look fine, I highly doubt it is those since I can jack the truck up and drop it and feel the pop in various parts on the right side which is making me scratch my head. My next move is replacing the lower ball joints and the sway bar links again, though they both seem solid when using a pry bar today when putting the spacers on the control arm in. I am also planning on new upper control arms shortly, then maybe the CV axle, I already replaced the drivers side CV axle. Has anyone found an oddity that could be causing this? I have not found any witness marks of anything hitting or anything loose or flexing out of the ordinary. The transfer case is out of question also as it is in 4x2 when it pops.
 

·
Registered
2017 titan sv 4x4 with tech, convinience, tow, navigation, and Texas packages
Joined
·
6,209 Posts
my truck had a weird noise when i turned right, like a washer ringing under a nut that wasn't tightened, when i first got it. the dealer cold never find it and i complained a few times. when they replaced the motor, they found the motor mount was cross threaded into the frame mount so they had to cut and reweld in something. after that, the noise went away.

and some people have found mag lights in their vehicles and sockets in the frame
 
1 - 3 of 3 Posts
Top