Nissan Titan Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
310 Posts
Discussion Starter #1
Just got my last tune from Joe after installing JBA long tubes and Cajun catted bpipes. Holy $h!t!!!! This is night and day difference. The pulling power is exhilarating. This is my 3rd titan and exactly what I needed to make it feel like a different truck.

Joe/Seymore is the absolute best and I just don't know how he is able to always be available to answer questions and provide updated tunes at the pace he does, but, he does, and its amazing.

Cant say enough good things about this setup. If anyone is on the fence and looking to wake up the beast, this setup is a VERY, VERY noticeable improvement!!!

Sitting at work, dreaming of hammering on my truck. Cant wait to hook the boat up and see what the difference is there...

-Mike
 

·
Registered
Joined
·
118 Posts
im going through the same right now (dropped my 05 off 2 hours ago) non cattted b-s for me. can't wait to see what a diff it makes!
 
  • Like
Reactions: seymore4

·
Registered
Joined
·
741 Posts
Just got my last tune from Joe after installing JBA long tubes and Cajun catted bpipes. Holy $h!t!!!! This is night and day difference. The pulling power is exhilarating. This is my 3rd titan and exactly what I needed to make it feel like a different truck.

Joe/Seymore is the absolute best and I just don't know how he is able to always be available to answer questions and provide updated tunes at the pace he does, but, he does, and its amazing.

Cant say enough good things about this setup. If anyone is on the fence and looking to wake up the beast, this setup is a VERY, VERY noticeable improvement!!!

Sitting at work, dreaming of hammering on my truck. Cant wait to hook the boat up and see what the difference is there...

-Mike
I hate you.

And so, my recent trend of stalking any and all Uprev related threads so I can live vicariously through the OP while awaiting the arrival of my own cable, continues...
 
  • Like
Reactions: seymore4

·
Registered
Joined
·
404 Posts
Good stuff I just ordered my stage 1 yesterday best customer experience I have ever had was on the phone with Jeff for about 30min answering my questions an bsing. Joe was quick to reply for the Uprev an shipped this morning I am looking forward installing can't speak highly enough of these two service an experience.
 
  • Like
Reactions: seymore4

·
Registered
Joined
·
37 Posts
Its nice to deal directly w/ the people whom run the business and not some crony that doesn't care about the reputation and service of whom they are working. Today's day and age of customer service is usually "I don't know" with the extra look of, "why doesn't this ahole leave me alone so I can play on my phone"

Its great service, knowledge and patience that will keep me saying nothing but good things about Cajun to anyone who will listen.
 

·
Vendor
Joined
·
7,921 Posts
We realize customer service and word of mouth is important and sale or no sale you will get that from Cajun. We appreciate the business and recommendations.
 

·
Registered
Joined
·
310 Posts
Discussion Starter #12
Anyone else have an annoying rattle on startup after header install? Mine rattles like a b!tch for about 2 minutes after startup, goes away once the truck is warm which is weird. I crawled all under the truck and cant find anything loose and cant pinpoint exactly where its coming from. Had headers re-torqued, bpipes are buttoned up (although they didnt fit very well on drivers side, the end that connects to the ypipe was a little off kilter so one bolt is crooked, but tight). I cant find anything loose, but something is rattling.

Maybe the headers are touching engine mount???

Any suggestions appreciated.

-Mike
 

·
Registered
Joined
·
912 Posts
Anyone else have an annoying rattle on startup after header install? Mine rattles like a b!tch for about 2 minutes after startup, goes away once the truck is warm which is weird. I crawled all under the truck and cant find anything loose and cant pinpoint exactly where its coming from. Had headers re-torqued, bpipes are buttoned up (although they didnt fit very well on drivers side, the end that connects to the ypipe was a little off kilter so one bolt is crooked, but tight). I cant find anything loose, but something is rattling.

Maybe the headers are touching engine mount???

Any suggestions appreciated.

-Mike
I know when I started mine for the first time, the b pipes weren't tightened all the way and the oem metal gasket would flap from the exhaust making a horrible noise. Maybe your headers are resting on the motor mount. Heat shields tightened up?

Sent from my SM-N910V using Tapatalk
 

·
Registered
Joined
·
37 Posts
When putting mine on I had to clearance the fit between the motor mount and the header. It is very hard to see in there so I used a feeler gauge to check everything before final button up. I would make sure you don't have any fitment issues as it could potentially rub a hole through the header if you let it go.
Also on the fitment of the headers and bpipes to the rest of the exhaust, I loosened up the Y pipe (cut the clamp) and sprayed the crap out of the Y pipe with panther piss in order to get it worked loose in order to get everything to line up nicely and not bind the heck out of the connections and bolts.

Hope you can find some use out of this info good luck with the rattle.
 

·
Registered
Joined
·
310 Posts
Discussion Starter #15
Thanks for the info. Ill have to have the headers looked at to make sure they're not rubbing, definitely don't want to rub a hole in those. and im not getting back in there to deal with that, Ill take it somewhere to have it looked at.

The heat shields that are back by the bpipes are good and not rattling. We removed the crossmember to get at the motor mounts and I thought maybe it was loose, but it is also secure and not rattling. The problem is I only have a few minutes to crawl around and grab stuff while I can hear the rattling before things get too hot...

My exhaust is welded up so I cant adjust the ypipe.

The search continues...
 

·
Vendor
Joined
·
7,921 Posts
Check motor mount clearance on driver side header. The mount may need a little clearancing with a flap disk, some do and some have plenty.
 

·
Registered
Joined
·
310 Posts
Discussion Starter #17
Thanks for the info, i'm assuming the header will have to be removed to use the flap disk on the motor mount?
 
1 - 20 of 21 Posts
Top