Nissan Titan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Finally getting my power steps on the truck after them being backordered and then when they arrived no time to install. First, I've read up on all I can find on the power steps and the install thread on these. What I've run into on the left side is that the white plastic plug appears to be under either the outer seat mount or where the sub bolts to the floor. I don't have a 'floor grommet behind the front bracket' as the instructions say. I have a plug pulled and great access on the passenger side. There are two white plugs on the passenger side, one on the drivers side. Do I have to pull the left seat and sub to get access to the left plug? Or is there a simpler way to get the trigger wire through the floor?

I've found a couple of changes from the install thread krh2 wrote and when I get mine completed, I'll post any updates.

Thanks,
Troy
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #2 ·
OK, I found out that white square plug you see under the driver's side that is very close to outside seat bolt, call it left rear bolt for the front seat, is used to receive the bolt that secures the RF subwoofer. That means if you have the RF sub, that plug isn't available to you to run a wire through. I'm stumped on where to run the trigger wire, guess it's off to the store for a rubber grommet and drill a hole. Would love to hear from anyone who has installed the Power Steps on an LE and how they handled this.

Turns out I had to time to put down the tools and leave it alone since last weekend. When I went to install the motor brackets, only 3 of the 5 needed holes were drilled. That pretty much stopped me. Customer support was very helpful and I hope to have the correct motor brackets tomorrow.

Troy
 

·
Registered
Joined
·
3,324 Posts
Finally getting my power steps on the truck after them being backordered and then when they arrived no time to install. First, I've read up on all I can find on the power steps and the install thread on these. What I've run into on the left side is that the white plastic plug appears to be under either the outer seat mount or where the sub bolts to the floor. I don't have a 'floor grommet behind the front bracket' as the instructions say. I have a plug pulled and great access on the passenger side. There are two white plugs on the passenger side, one on the drivers side. Do I have to pull the left seat and sub to get access to the left plug? Or is there a simpler way to get the trigger wire through the floor?

I've found a couple of changes from the install thread krh2 wrote and when I get mine completed, I'll post any updates.

Thanks,
Troy
I installed my amp steps and had a small looking circle that if you push with a flathead it will push up enough to slip the wires through.
2011-03-03_16-15-33_289.jpg
 
1 - 5 of 5 Posts
Top